Bug 113551 - TB boot_gui.py:238:writeBootFile:IndexError: list index out of range
TB boot_gui.py:238:writeBootFile:IndexError: list index out of range
Status: CLOSED DUPLICATE of bug 109266
Product: Fedora
Classification: Fedora
Component: redhat-config-boot (Show other bugs)
1
athlon Linux
low Severity low
: ---
: ---
Assigned To: Harald Hoyer
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-14 22:24 EST by charles may
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description charles may 2004-01-14 22:24:49 EST
Description of problem:
"bootloader" barfs when changing preferred load

Version-Release number of selected component (if applicable):
2.4.22  2149

How reproducible:
every time

Steps to Reproduce:
1.run bootloader from Gnome while root and change default selection
2.attached output file
3.my PC told me to report this
  
Actual results:
annoying at best, I will just vim grub.conf in /boot/grub to change it


Component: redhat-config-boot
Version: 0.1.6
Summary: TB2e18078e boot_gui.py:238:writeBootFile:IndexError: list
index out of range
Traceback (most recent call last):
  File
"/usr/lib/python2.2/site-packages/rhpl/firstboot_gui_window.py", line
83, in okClicked
    if self.apply():
  File
"/usr/src/build/321181-i386/install/usr/share/firstboot/modules/boot_gui.py",
line 197, in apply
    self.writeBootFile(num)
  File
"/usr/src/build/321181-i386/install/usr/share/firstboot/modules/boot_gui.py",
line 238, in writeBootFile
    if tokens[0].find("=") >= 0:
IndexError: list index out of range

Local variables in innermost frame:
defaultset: 1
timeoutset: 1
i: 12
self: <boot_gui.BootWindow instance at 0x85217e4>
lines: ['# grub.conf generated by anaconda\n', '#\n', '# Note that you
do not have to rerun grub after making changes to this file\n', '#
NOTICE:  You do not have a /boot partition.  This means that\n', '#  
       all kernel and initrd paths are relative to /, eg.\n', '#     
    root (hd0,0)\n', '#          kernel /boot/vmlinuz-version ro
root=/dev/sda1\n', '#          initrd /boot/initrd-version.img\n',
'#boot=/dev/sda\n', 'default=1\n', 'timeout=10\n',
'splashimage=(hd0,0)/boot/grub/splash.xpm.gz\n', '\n', '\n', 'title
Fedora Core (2.6.1)\n', '\troot (hd0,0)\n', '\tkernel
/boot/vmlinuz-2.6.1 ro root=LABEL=/ hda=ide-scsi rhgb\n', '\tinitrd
/boot/initrd-2.6.1.img\n', '\n', '\n', 'title Fedora Core
(2.4.22-1.2149.nptl)\n', '\troot (hd0,0)\n', '\tkernel
/boot/vmlinuz-2.4.22-1.2149.nptl ro root=LABEL=/ hda=ide-scsi rhgb\n',
'\tinitrd /boot/initrd-2.4.22-1.2149.nptl.img\n', '\n', '\n', 'title
Fedora Core (2.4.24)\n', '\troot (hd0,0)\n', '\tkernel
/boot/vmlinuz-2.4.24.nptl ro root=LABEL=/ hda=ide-scsi rhgb\n',
'\tinitrd /boot/initrd-2.4.24.nptl.img\n', '\n', '\n', 'title Fedora
Core (2.4.22-1.2140.nptl)\n', '\troot (hd0,0)\n', '\tkernel
/boot/vmlinuz-2.4.22-1.2140.nptl ro root=LABEL=/ hda=ide-scsi rhgb\n',
'\tinitrd /boot/initrd-2.4.22-1.2140.nptl.img\n', '\n', 'title Fedora
Core (2.4.22-1.2129.nptl)\n', '\troot (hd0,0)\n', '\tkernel
/boot/vmlinuz-2.4.22-1.2129.nptl ro root=LABEL=/ hda=ide-scsi rhgb\n',
'\tinitrd /boot/initrd-2.4.22-1.2129.nptl.img\n', '\n', '\n', 'title
DOS\n', '\trootnoverify (hd0,4)\n', '\tchainloader +1\n']
iter: <GtkTreeIter at 0x870b240>
tokens: []
toplevel: {}
miceDict: {}
num: 1
fd: <closed file '/etc/grub.conf', mode 'r' at 0x870ab30>
timeout: 10
line: 



Expected results:
changes startup kernal without a fuss

Additional info:
I probably have hosed up my computer playing hard core newbie, yet
thats how ya learn.
2.6 runs pretty good by the way (when you can get it to compile!!)
PS check out a third party driver (open source) for the nvidia nvnet
inetegrated nic, I cant get the #!$%#! to works.
Comment 1 Harald Hoyer 2004-03-04 03:25:27 EST

*** This bug has been marked as a duplicate of 109266 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:00:46 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.