Bug 1135518 - yum -C doesn't handle file: repositories correctly.
Summary: yum -C doesn't handle file: repositories correctly.
Keywords:
Status: CLOSED DUPLICATE of bug 1125387
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 20
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-29 13:57 UTC by Ira Cooper
Modified: 2014-10-14 18:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-14 18:49:29 UTC


Attachments (Terms of Use)

Description Ira Cooper 2014-08-29 13:57:55 UTC
Description of problem:

When you use yum with a file: repository and a http: repository.  The file repository is not properly checked when you use -C.  Given that it is on the localhost, this seems wrong, or there should be a way to force it into the cache.

Version-Release number of selected component (if applicable):

ira@ira-t430:~
[/dev/pts/0](1004/1)$ yum --version
3.4.3
  Installed: rpm-4.11.2-2.fc20.x86_64 at 2014-06-01 16:16
  Built    : Fedora Project at 2014-02-18 07:24
  Committed: Panu Matilainen <pmatilai@redhat.com> at 2014-02-18

  Installed: yum-3.4.3-152.fc20.noarch at 2014-07-07 15:29
  Built    : Fedora Project at 2014-06-18 12:25
  Committed: James Antill <james at fedoraproject.org> at 2014-06-18



How reproducible:

100%.

Steps to Reproduce:

Have a http repo, and a file repo... and use yum -C to try and get things from the file repo.  It will fail.

Actual results:

yum does not pull in packages from file: repositories when --offline is used.

Expected results:

yum should pull in packages from file: repositories when --offline is used.

Additional info:

I actually reproduced this using mock, and some redhat internal build stuff.  I'm happy to share that privately.

Comment 1 Valentina Mukhamedzhanova 2014-09-02 13:18:07 UTC
Hi, a reproducer would be helpful.

Comment 2 Valentina Mukhamedzhanova 2014-10-14 18:49:29 UTC

*** This bug has been marked as a duplicate of bug 1125387 ***


Note You need to log in before you can comment on or make changes to this bug.