Bug 1135542 - Prevent package installation from UI if katello-agent is not installed
Summary: Prevent package installation from UI if katello-agent is not installed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-29 14:44 UTC by sthirugn@redhat.com
Modified: 2019-09-26 13:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:44:18 UTC
Target Upstream Version:


Attachments (Terms of Use)
package installation tasks goes on forever (91.11 KB, application/octet-stream)
2014-08-29 14:45 UTC, sthirugn@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description sthirugn@redhat.com 2014-08-29 14:44:51 UTC
Description of problem:
Prevent package installation from UI if katello-agent is not installed

Version-Release number of selected component (if applicable):
GA Snap 7 - Satellite-6.0.4-RHEL-6-20140828.0

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.23-1.el6_5.noarch
* candlepin-common-1.0.1-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.23-1.el6_5.noarch
* candlepin-tomcat6-0.9.23-1.el6_5.noarch
* elasticsearch-0.90.10-6.el6sat.noarch
* foreman-1.6.0.42-1.el6sat.noarch
* foreman-compute-1.6.0.42-1.el6sat.noarch
* foreman-gce-1.6.0.42-1.el6sat.noarch
* foreman-libvirt-1.6.0.42-1.el6sat.noarch
* foreman-ovirt-1.6.0.42-1.el6sat.noarch
* foreman-postgresql-1.6.0.42-1.el6sat.noarch
* foreman-proxy-1.6.0.30-1.el6sat.noarch
* foreman-selinux-1.6.0.14-1.el6sat.noarch
* foreman-vmware-1.6.0.42-1.el6sat.noarch
* katello-1.5.0-30.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.6-1.el6sat.noarch
* katello-installer-0.0.62-1.el6sat.noarch
* openldap-2.4.23-34.el6_5.1.x86_64
* openldap-devel-2.4.23-34.el6_5.1.x86_64
* pulp-katello-0.3-4.el6sat.noarch
* pulp-nodes-common-2.4.1-0.5.rc1.el6sat.noarch
* pulp-nodes-parent-2.4.1-0.5.rc1.el6sat.noarch
* pulp-puppet-plugins-2.4.1-0.5.rc1.el6sat.noarch
* pulp-puppet-tools-2.4.1-0.5.rc1.el6sat.noarch
* pulp-rpm-plugins-2.4.1-0.5.rc1.el6sat.noarch
* pulp-selinux-2.4.1-0.5.rc1.el6sat.noarch
* pulp-server-2.4.1-0.5.rc1.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch

How reproducible:
Always

Steps to Reproduce:
1. Install a client (without katello-agent installed) to satellite6
2. Navigate to UI -> Hosts -> Content Hosts -> Select the Host -> Packages Tab -> 
3. Type a package name and click Perform.

Actual results:
The install action goes on and on (see screenshot)

Expected results:
Satellite should be smart enough to return an error message saying "katello-agent is not running"

Additional info:

Comment 1 sthirugn@redhat.com 2014-08-29 14:45:29 UTC
Created attachment 932696 [details]
package installation tasks goes on forever

Comment 2 sthirugn@redhat.com 2014-08-29 14:46:06 UTC
FWIW - The errata installation is not possible in UI without katello-agent installed.

Comment 4 sthirugn@redhat.com 2014-08-29 14:56:21 UTC
The running task never completed.  So this will prevent any further action on the task:

Manual steps to stop this task
1. Click on Content Host
2. Go to Tasks tab
3. Click on the Task
4. Click More Details
5. Click Fore Unlock.  Confirm Force Unlock

Comment 5 sthirugn@redhat.com 2014-08-29 14:57:36 UTC
NOTE:
This issue happens in CLI also:

# hammer -u admin -p changeme content-host package install --content-host=mgmt8.rhq.lab.eng.bos.redhat.com --organization-id=3 --packages=emacs
[..............................                               ] [50%]

The CLI never stops and I had to do Comment 4 above to Force Unlock.

Comment 6 Brad Buckingham 2015-09-02 20:41:25 UTC
With Satellite 6.1.1 GA, the behavior is now different.

RPMs:
ruby193-rubygem-katello-2.2.0.66-1.el7sat.noarch
foreman-1.7.2.34-1.el7sat.noarch

In the UI, when the user visits the Packages pane, they will be shown the following message:

"The katello-agent package is required to manage packages on this Host. Please install the katello-agent package to manage packages on rhel7-client.test. To install the package, connect directly to the host from a terminal and use yum."

If the user does try to install a package, it will create a task; however, the task completes in about 30 seconds with the following task details:

"Host did not respond within 20 seconds. Is katello-agent installed and goferd running on the Host?"


Regarding Errata, it appears to have the same behavior as above.

Comment 7 Brad Buckingham 2015-09-02 20:44:39 UTC
Moving to ON_QA based on the improved behavior.

Comment 8 sthirugn@redhat.com 2015-09-03 20:30:51 UTC
As per Comment 6, behavior is greatly improved in Sat 6.1.1.  Moving this to VERIFIED.

Comment 11 errata-xmlrpc 2016-07-27 08:44:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.