Bug 1135553 - QueryInterceptor & ClusterRegistry racing conditions fixes
Summary: QueryInterceptor & ClusterRegistry racing conditions fixes
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Data Grid 6
Classification: JBoss
Component: Infinispan
Version: 6.3.1,6.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ER2
: 6.3.1
Assignee: Tristan Tarrant
QA Contact: Martin Gencur
URL:
Whiteboard:
: 1135575 (view as bug list)
Depends On:
Blocks: 1139669
TreeView+ depends on / blocked
 
Reported: 2014-08-29 15:22 UTC by Gustavo Fernandes
Modified: 2019-09-12 07:58 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously in Red Hat JBoss Data Grid, race conditions caused intermittent timeouts in indexed queries and missing @Indexed annotation errors. This is now fixed in JBoss Data Grid 6.3.1 and these race conditions work as expected and do not cause unexpected timeouts and annotation errors.
Clone Of:
: 1139669 (view as bug list)
Environment:
Last Closed: 2015-01-26 14:04:58 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Issue Tracker ISPN-4604 Major Resolved Race condition in the QueryInterceptor involving SearchFactory 2017-05-26 08:12:28 UTC
Red Hat Issue Tracker ISPN-4612 Major Resolved TimeoutException during preparetx when putting to the ClusterRegistry 2017-05-26 08:12:28 UTC
Red Hat Issue Tracker ISPN-4627 Minor Resolved QueryInterceptor start() event mutates the SearchFactory multiple times 2017-05-26 08:12:28 UTC

Description Gustavo Fernandes 2014-08-29 15:22:19 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Gustavo Fernandes 2014-08-29 16:14:38 UTC
PR jdg 6.3.x: https://github.com/infinispan/jdg/pull/215

Comment 3 Gustavo Fernandes 2014-08-29 16:34:51 UTC
PR jdg 6.4.x:  https://github.com/infinispan/jdg/pull/216

Comment 4 Gustavo Fernandes 2014-08-29 16:59:46 UTC
*** Bug 1135575 has been marked as a duplicate of this bug. ***

Comment 5 Adrian Nistor 2014-08-30 13:42:36 UTC
Integrated in both 6.3.x and 6.4.x


Note You need to log in before you can comment on or make changes to this bug.