Bug 1135731 - Hideous font rendering.
Summary: Hideous font rendering.
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: urw-fonts
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-30 23:28 UTC by Ralph Loader
Modified: 2015-02-09 10:44 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-09 10:44:22 UTC


Attachments (Terms of Use)
Screenshot of http://www.science20.com/quantum_diaries_survivor (91.40 KB, application/octet-stream)
2014-08-30 23:28 UTC, Ralph Loader
no flags Details

Description Ralph Loader 2014-08-30 23:28:44 UTC
Created attachment 933025 [details]
Screenshot of http://www.science20.com/quantum_diaries_survivor

After upgrading to f21, I am seeing firefox rendering fonts awfully on many websites.

It looks like the font has been rendered non-anti-aliased, and then scaled by a non-integer ratio.

Examples are facebook and http://www.science20.com/quantum_diaries_survivor.

Comment 1 Ralph Loader 2014-09-14 08:02:04 UTC
fc-match says that 'helvetica' is getting mapping to an old X11 font:

$ fc-match -v helvetica
...
	file: "/usr/share/fonts/X11/100dpi/helvR08-ISO8859-1.pcf.gz"(w)

Isn't it about time that we just deleted any code path using old X11 fonts when they are not explicitly asked for?

Comment 2 Rick Elrod 2014-10-16 08:29:16 UTC
Seeing this as well...

Restoring my sanity/working around it temporarily by mapping Helvetica to Nimbus Sans L in ~/.config/fontconfig/fonts.conf:

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
<alias binding="same">
  <family>Helvetica</family>
  <prefer>
    <family>Nimbus Sans L</family>
  </prefer>
</alias>
</fontconfig>

Comment 3 Martin Stransky 2015-01-21 14:02:15 UTC
IMHO should be fixed in fontconfig.

Comment 4 Akira TAGOH 2015-01-22 08:06:47 UTC
If we prefer Nimbus Sans L for Helvetica alternatives, it should be fixed in urw-fonts with adding the above config to the package. or adding the following to xorg-x11-fonts-ISO8859-1-100dpi package:

<fontconfig>
  <selectfont>
    <rejectfont>
      <glob>/usr/share/fonts/X11/100dpi/*.gz</glob>
    </rejectfont>
  </selectfont>
</fontconfig>

if those fonts are totally useless for applications using fontconfig.
Either way, I expect to see the fix in the package other than fontconfig because it avoids frequent updates of fontconfig for non-binary updates and unnecessary updates for those who don't install the problematic font packages.

I'm not sure how much rejecting X11 fonts affects other applications. reassigning to urw-fonts at this point.

Comment 5 Ngo Than 2015-01-29 17:26:10 UTC
i cannot reproduce this issue on my machine with xorg-x11-fonts-ISO8859-1-100dpi and urw-fonts-2.4-19.fc21 installed.

fc-match -v helvetica
Pattern has 29 elts (size 32)
        family: "Nimbus Sans L"(s)
        style: "Regular"(w)
        slant: 0(i)(s)
        weight: 80(i)(s)
        width: 100(i)(s)
        size: 12(f)(s)
        pixelsize: 12.5(f)(s)
        foundry: "urw"(w)
        hintstyle: 3(i)(s)
        hinting: True(s)
        verticallayout: False(s)
        autohint: False(s)
        globaladvance: True(s)
        file: "/usr/share/fonts/default/Type1/n019003l.pfb"(w)
        index: 0(i)(w)
        outline: True(w)
        scalable: True(w)
        dpi: 75(f)(s)
        scale: 1(f)(s)
        charset: 
        0000: 00000000 ffffffff ffffffff 7fffffff 00000000 ffffffff ffffffff ffffffff
        0001: ffffffff ffffffff ffffffff ffffffff 00040000 00000000 00000000 00000000
        0002: 0f000000 00000000 00000000 00000000 00000000 00000000 3f0002c0 00000000
        0003: 00000000 00000000 00000000 00000000 00100000 10000000 00000000 00000000
        0004: ffffffff ffffffff ffffffff 00000000 fffff000 ffffffff ffff199f 033fffff
        0020: 77180000 06010047 00000010 00000000 00000000 00001000 00000000 00000000
        0021: 00400000 00000004 00000000 00000000 00000000 00000000 00000000 00000000
        0022: 46260044 00000000 00000000 00000031 00000000 00000000 00000000 00000000
        0025: 00000000 00000000 00000000 00000000 00000000 00000000 00000400 00000000
        00f6: 00000000 00000000 00000000 00000000 00000000 00000000 000001f8 00000000
        00fb: 00000006 00000000 00000000 00000000 00000000 00000000 00000000 00000000
(w)
        lang: aa|ab|af|av|ay|ba|be|bg|bi|br|bs|bua|ca|ce|ch|chm|co|cs|cv|da|de|en|eo|es|et|eu|fi|fj|fo|fr|fur|fy|gd|gl|gv|ho|hr|hu|ia|id|ie|ik|io|is|it|kaa|ki|kk|kl|kum|kv|ky|la|lb|lez|lt|lv|mg|mh|mk|mo|mt|nb|nds|nl|nn|no|nr|nso|ny|oc|om|os|pl|pt|rm|ro|ru|sah|se|sel|sh|sk|sl|sma|smj|smn|so|sq|sr|ss|st|sv|sw|tg|tk|tl|tn|tr|ts|tt|tyv|uk|uz|vo|vot|wa|wen|wo|xh|yap|zu|an|crh|csb|fil|hsb|ht|jv|kj|ku-tr|kwm|lg|li|mn-mn|ms|na|ng|pap-an|pap-aw|rn|rw|sc|sg|sn|su|za(s)
        fontversion: 0(i)(s)
        fontformat: "Type 1"(w)
        embeddedbitmap: True(s)
        decorative: False(s)
        namelang: "de"(s)
        prgname: "fc-match"(s)
        hash: "sha256:cba3127299addab69e12b5ff07955b4c065dd0e631a6736616cd3423aa0be6cd"(w)
        postscriptname: "NimbusSanL-Regu"(w)

could you please give more infos how i can reproduce this issue?

Thanks

Comment 6 Ralph Loader 2015-02-08 05:56:38 UTC
I can no longer reproduce this.  Is this still happening for anyone else?

Comment 7 Ngo Than 2015-02-09 10:44:22 UTC
reporter and me cannot reproduce this issue anymore. I decided to close this bug as "WORKSFORME". Feel free to reopen this again if someone can reproduce it.

Thanks


Note You need to log in before you can comment on or make changes to this bug.