Bug 1135768 - Switching off Network time doesn't affect installed system
Summary: Switching off Network time doesn't affect installed system
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Shea
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-31 11:12 UTC by Branko Grubić
Modified: 2014-10-20 23:01 UTC (History)
9 users (show)

Fixed In Version: anaconda-21.48.10-1.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-20 23:01:56 UTC
Type: Bug


Attachments (Terms of Use)
anaconda-ks.cfg (1.09 KB, text/plain)
2014-09-23 15:48 UTC, Branko Grubić
no flags Details
anaconda.log (20.27 KB, text/plain)
2014-09-23 15:48 UTC, Branko Grubić
no flags Details
ifcfg.log (3.63 KB, text/plain)
2014-09-23 15:49 UTC, Branko Grubić
no flags Details
journal.log (1014.54 KB, text/plain)
2014-09-23 15:50 UTC, Branko Grubić
no flags Details
packaging.log (208 bytes, text/plain)
2014-09-23 15:51 UTC, Branko Grubić
no flags Details
program.log (33.27 KB, text/plain)
2014-09-23 15:52 UTC, Branko Grubić
no flags Details
storage.log (152.78 KB, text/plain)
2014-09-23 15:53 UTC, Branko Grubić
no flags Details

Description Branko Grubić 2014-08-31 11:12:23 UTC
Description of problem:
I saw this in f20 final anaconda installer, after install 'chronyd' service is active/running, but I selected/switched to OFF network option in timezone settings. Now tested f21 alpha-tc5 workstation live image, same problem.

I see in /root/anaconda-ks.cfg

# System timezone
timezone <xxx>/<xxx> --isUtc --nontp

I don't know how it works, but looks like '--nontp' is selected, but doesn't work later after install 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Branko Grubić 2014-09-01 18:00:36 UTC
Just want to confirm this on f20, I tested f20 final KDE live, after install, same problem 'chronyd' running and I switched network time option to OFF in anaconda
"# System timezone" options same to those of f21 install, so '--nontp' is there.

Comment 2 David Shea 2014-09-04 14:49:30 UTC
Can you attach the logs from the installation to this bug? --nontp is working fine for me in the f21 alpha-tc5 installer.

Comment 3 Branko Grubić 2014-09-07 07:22:42 UTC
Sorry, I cannot test this anymore.
Please close this bug.

Comment 4 Branko Grubić 2014-09-23 15:47:49 UTC
After install f21 workstation live image (alpha_rc1), I switched network time in installer to OFF, chronyd is running.
I'll attach anaconda-ks file, and log files.

Comment 5 Branko Grubić 2014-09-23 15:48:31 UTC
Created attachment 940483 [details]
anaconda-ks.cfg

Comment 6 Branko Grubić 2014-09-23 15:48:55 UTC
Created attachment 940484 [details]
anaconda.log

Comment 7 Branko Grubić 2014-09-23 15:49:32 UTC
Created attachment 940485 [details]
ifcfg.log

Comment 8 Branko Grubić 2014-09-23 15:50:47 UTC
Created attachment 940487 [details]
journal.log

Comment 9 Branko Grubić 2014-09-23 15:51:24 UTC
Created attachment 940488 [details]
packaging.log

Comment 10 Branko Grubić 2014-09-23 15:52:01 UTC
Created attachment 940489 [details]
program.log

Comment 11 Branko Grubić 2014-09-23 15:53:28 UTC
Created attachment 940490 [details]
storage.log

There was also ks-script-c06CvO.log in /var/log/anaconda, but it is empty 0b

Comment 12 Branko Grubić 2014-09-23 15:56:06 UTC
I'm not sure how this work, but maybe this is not anaconda bug?

# systemctl status chronyd
● chronyd.service - NTP client/server
   Loaded: loaded (/usr/lib/systemd/system/chronyd.service; enabled)
   Active: active (running) since Tue 2014-09-23 17:39:10 CEST; 4min 46s ago
  Process: 584 ExecStartPost=/usr/libexec/chrony-helper add-dhclient-servers (code=exited, status=0/SUCCESS)
  Process: 555 ExecStart=/usr/sbin/chronyd $OPTIONS (code=exited, status=0/SUCCESS)
 Main PID: 564 (chronyd)
   CGroup: /system.slice/chronyd.service
           └─564 /usr/sbin/chronyd

Sep 23 17:39:09 localhost.localdomain chronyd[564]: chronyd version 1.31-pre1 starting
Sep 23 17:39:09 localhost.localdomain chronyd[564]: Generated key 1
Sep 23 17:39:29 localhost.localdomain chronyd[564]: Selected source 46.240.140.176
Sep 23 17:39:29 localhost.localdomain chronyd[564]: System clock wrong by 1.081258 seconds, adjustment started


When I disable it
# systemctl disable chronyd
Removed symlink /etc/systemd/system/multi-user.target.wants/chronyd.service.

Comment 13 David Shea 2014-09-23 16:00:11 UTC
Flipping the switch doesn't turn ntp off in the installer environment, it only controls whether ntp is enabled or disabled in the installed system. I suppose you could argue that we should turn it off in the installer as well.

Comment 14 Branko Grubić 2014-09-23 16:03:52 UTC
This is all after install, when booted to installed system.

Comment 15 David Shea 2014-09-23 18:17:59 UTC
Gotcha. The live image is being created with chronyd enabled. Normally it is installed disabled and anaconda enables the service if --nontp is not specified, so this is a bug in the creation of the live payload.

Comment 16 Kevin Fenzi 2014-09-27 16:58:52 UTC
Well, we aren't doing anything special in the live kickstarts... chrony is enabled by default as part of the preset. Additionally, don't we want chrony running in the live system? 

Can't anaconda disable it if it does see --nontp?

Comment 17 David Shea 2014-10-06 12:52:35 UTC
Yeah, ok.

Comment 18 Fedora Update System 2014-10-15 13:07:50 UTC
anaconda-21.48.10-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/anaconda-21.48.10-1.fc21

Comment 19 Fedora Update System 2014-10-16 17:18:34 UTC
Package anaconda-21.48.10-1.fc21, pykickstart-1.99.63-2.fc21, python-blivet-0.61.5-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-21.48.10-1.fc21 pykickstart-1.99.63-2.fc21 python-blivet-0.61.5-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-12944/pykickstart-1.99.63-2.fc21,python-blivet-0.61.5-1.fc21,anaconda-21.48.10-1.fc21
then log in and leave karma (feedback).

Comment 20 Fedora Update System 2014-10-20 23:01:56 UTC
anaconda-21.48.10-1.fc21, pykickstart-1.99.63-2.fc21, python-blivet-0.61.5-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.