Bug 1135918 - Clear ("x") link missing from search box
Summary: Clear ("x") link missing from search box
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: Tomer Brisker
QA Contact: Corey Welton
URL:
Whiteboard: Verified in Upstream
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-01 07:42 UTC by Dominic Cleal
Modified: 2019-06-13 21:25 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-15 18:19:49 UTC
Target Upstream Version:


Attachments (Terms of Use)
comparison screenshot (8.21 KB, application/octet-stream)
2014-09-01 07:42 UTC, Dominic Cleal
no flags Details
cross(x) to clear search text from search box on Hosts page (75.96 KB, image/png)
2015-09-08 10:14 UTC, Sachin Ghai
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1911 0 normal SHIPPED_LIVE Satellite 6.1.3 bug fix update 2015-10-15 22:19:19 UTC

Description Dominic Cleal 2014-09-01 07:42:12 UTC
Created attachment 933265 [details]
comparison screenshot

Description of problem:
The clear button (an "x" typically in the bottom right hand corner) is missing from search boxes in the web UI.

Version-Release number of selected component (if applicable):
Satellite-6.0.4-RHEL-6-20140829.0

How reproducible:
Always

Steps to Reproduce:
1. Hosts > All hosts
2. enter a search ("test"), click Search
3. look for an "x" or clear link in the search box

Actual results:
clear link missing

Expected results:
"x" in bottom right of box

Additional info:
patternfly related I suppose

Comment 1 RHEL Program Management 2014-09-01 07:53:07 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 5 Sachin Ghai 2015-09-08 10:13:11 UTC
Verified with upstream:

foreman-release-1.10.0-0.develop.201509041547git84f7fc6.el6.noarch
foreman-1.10.0-0.develop.201509041547git84f7fc6.el6.noarch
katello-2.4.0-6.nightly.el6.noarch
katello-installer-base-2.4.0-1.nightly.201509040043gitb37b92b.el6.noarch
katello-installer-2.4.0-1.nightly.201509040043gitb37b92b.el6.noarch
tfm-rubygem-hammer_cli_foreman-0.3.0-2.201508261233git7334971.el6.noarch
tfm-rubygem-hammer_cli-0.3.0-2.201508280738git8a70aa0.el6.noarch
tfm-rubygem-hammer_cli_katello-0.0.17-4.el6.noarch


I can see the cross(x) on search box to clear the search text. Please see the screenshot from "hosts" page.  

Please note that I browsed other entities too to double check this. So far I can see that on every webUI page.

Comment 6 Sachin Ghai 2015-09-08 10:14:03 UTC
Created attachment 1071283 [details]
cross(x) to clear search text from search box on Hosts page

Comment 7 Tomer Brisker 2015-09-08 12:26:12 UTC
This is a branding bug that only occurs in downstream, moving back to POST until fix is merged and bug can be tested downstream.

Comment 10 Corey Welton 2015-10-02 19:04:30 UTC
Verified in 6.1.3 compose #2

Comment 12 errata-xmlrpc 2015-10-15 18:19:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1911


Note You need to log in before you can comment on or make changes to this bug.