Bug 113605 - kernel-source rpm will not install because glibc is to new
kernel-source rpm will not install because glibc is to new
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-15 14:00 EST by Dan Hernandez
Modified: 2007-04-18 13:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:41:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Hernandez 2004-01-15 14:00:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a)
Gecko/20030728 Mozilla Firebird/0.6.1

Description of problem:
The server is a HP ml530 proliant.
My original kernel was 2.4.18-14
I used the redhat network update agent to install all new errata (some
97 components). Finally I installed the new 2.4.20-28.8 kernel.

Here is the problem. I've tried to install the
kernel-2.4.20-28.8.src.rpm and also the Kernel development kit in the
Packages utility in redhat. The kernel-2.4.20-28.8.src.rpm won't
install because it complains that glibc 2.2.93 is not present. I have
glibc-2.3.2-4.80.8 installed, a newer version. 
I've tried to rpm -ivh --force kernel-2.4.20-28.8. 
I tried to uninstall glibc but it wont let me.
I've tried to rpm -ivh --force and --oldversion the older
glibc-2.2.93-5 and I get: 
"error: glibc-2.2.93-5.i686.rpm: V3 DSA signature: BAD, key ID db42a60e
error: glibc-2.2.93-5.i686.rpm cannot be installed"

Now when I try to install the kernel development kit in the packages
utility (which i assume gives me the original 2.4.18-14 kernel source)
 it complains that glibc, openssl, openldap, cyrus and krb5-lib are
all not present. Which is not true, they are all also newere versions
than what the rpm install is looking for.

Finally I decided to extract the kernel source out of the rpm myself
and place it in the /usr/src/linux-2.4.20-28.8 using  rpm2cpio. I
extracted all the files fine as can be but the proliant support
utility then switched over to complaining about not finding library
files in reference to the new kernel source.

I don't desire to nit pick through files forever, the kernel source
rpm should be all I need to install. Any help on how I do this would
be greatly appreciated.

Version-Release number of selected component (if applicable):
kernel-2.4.20-28.8.src.rpm

How reproducible:
Always

Steps to Reproduce:
1.upgrade out of box redhat 8.0 (without kernel source kit) to all new
rhn suggested packeges
2.try to install kerenel source
3.try to uninstall packages that are "too new" for the kernel source
rpm to accept and install older packages it requires
    

Actual Results:  unlocatable package: glibc = 2.2.93
required by: glibc-devel

Expected Results:  Install kernel-source since glibc is simply newer
not missing.

Additional info:
Comment 1 Bugzilla owner 2004-09-30 11:41:47 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.