Bug 1136079 - 'Red Hat Access' fails to attach JDR report to new case if JON is under proxy
Summary: 'Red Hat Access' fails to attach JDR report to new case if JON is under proxy
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: UI
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ER03
: JON 3.3.0
Assignee: Libor Zoubek
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-01 15:34 UTC by Libor Zoubek
Modified: 2015-11-02 00:44 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-11 14:02:04 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1134367 None None None Never

Internal Links: 1134367

Description Libor Zoubek 2014-09-01 15:34:15 UTC
Description of problem:

rha-support-lib_java fails to attach file when proxy server with port and no authentication is set.

Version-Release number of selected component (if applicable):
rha-suport-lib 1.0.4
JON 3.3.0.ER1

How reproducible: always


Steps to Reproduce:
1. Login to JON as a admin user
2. Go to 'Administrator->Settings' add proxy server details
3. Open new case with JDR report.

Actual results:

Attaching fails with this error (I am including input configuration for rha_support-lib API class

17:29:11,857 INFO  [org.rhq.server.rhaccess.AttachmentsServlet] (http-/0.0.0.0:7080-2) Configuring API with Config [url=https://api.access.redhat.com, userAgent=redhat-access-plugin-jon-1.0.4, proxyURL=http://10.16.23.199, proxyPort=3128, proxyUser=null, proxyPassword=null, sessionTimeout=3000000, devel=false, brokered=true]
17:29:13,871 ERROR [org.rhq.server.rhaccess.AttachmentsServlet] (http-/0.0.0.0:7080-2) Failed to create attachment: com.redhat.gss.redhat_support_lib.errors.RequestException: 411 - Length Required
        at com.redhat.gss.redhat_support_lib.infrastructure.BaseQuery.add(BaseQuery.java:53) [redhat-support-lib-java-1.0.4.jbossorg-1.jar:]
        at com.redhat.gss.redhat_support_lib.infrastructure.Problems.diagnoseStr(Problems.java:45) [redhat-support-lib-java-1.0.4.jbossorg-1.jar:]
        at org.rhq.server.rhaccess.AttachmentsServlet.doPost(AttachmentsServlet.java:181) [classes:]
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:754) [jboss-servlet-api_3.0_spec-1.0.2.Final-redhat-1.jar:1.0.2.Final-redhat-1]
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:847) [jboss-servlet-api_3.0_spec-1.0.2.Final-redhat-1.jar:1.0.2.Final-redhat-1]
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:295) [jbossweb-7.4.0.Beta4.jar:7.4.0.Beta4]
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:214) [jbossweb-7.4.0.Beta4.jar:7.4.0.Beta4]
        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:231) [jbossweb-7.4.0.Beta4.jar:7.4.0.Beta4]
        at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:149) [jbossweb-7.4.0.Beta4.jar:7.4.0.Beta4]
        at org.jboss.as.jpa.interceptor.WebNonTxEmCloserValve.invoke(WebNonTxEmCloserValve.java:50) [jboss-as-jpa-7.4.0.Final-redhat-4.jar:7.4.0.Final-redhat-4]
        at org.jboss.as.jpa.interceptor.WebNonTxEmCloserValve.invoke(WebNonTxEmCloserValve.java:50) [jboss-as-jpa-7.4.0.Final-redhat-4.jar:7.4.0.Final-redhat-4]
        at org.jboss.as.web.security.SecurityContextAssociationValve.invoke(SecurityContextAssociationValve.java:169) [jboss-as-web-7.4.0.Final-redhat-4.jar:7.4.0.Final-redhat-4]
        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:145) [jbossweb-7.4.0.Beta4.jar:7.4.0.Beta4]
        at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:97) [jbossweb-7.4.0.Beta4.jar:7.4.0.Beta4]
        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:102) [jbossweb-7.4.0.Beta4.jar:7.4.0.Beta4]
        at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:340) [jbossweb-7.4.0.Beta4.jar:7.4.0.Beta4]
        at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:856) [jbossweb-7.4.0.Beta4.jar:7.4.0.Beta4]
        at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:653) [jbossweb-7.4.0.Beta4.jar:7.4.0.Beta4]
        at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:926) [jbossweb-7.4.0.Beta4.jar:7.4.0.Beta4]
        at java.lang.Thread.run(Thread.java:744) [rt.jar:1.7.0_51]

Expected results:


Additional info:

I've checked proxy server and it seems to work properly

Comment 1 Libor Zoubek 2014-09-04 14:31:42 UTC
This commit must not go to master, because it introduces declaration for rhq-rh-access.war deployment in EAR's jboss-deployment-structure.xml. And rhq-rh-access.war is not built by default for RHQ, so RHQ would fail to startup.

commit b188594dd5d3482e87740596255f2c96dd67a966
Author: Libor Zoubek <lzoubek@redhat.com>
Date:   Thu Sep 4 16:26:24 2014 +0200

    Bug 1136079 - 'Red Hat Access' fails to attach JDR report to new case if JON
    is under proxy
    
    Fixed by bumping redhat-support-lib-java to 2.0.5. This version migrated to
    resteasy 3.0.8 and introduced exclusions in RHQ EAR's
    jboss-deployment-structure.xml

Comment 2 Libor Zoubek 2014-09-04 14:37:45 UTC
Additional small commit - does not go to master aswell

commit 694eff5fbbfc0532e51d8e05a8c38e9a5a7ab37c
Author: Libor Zoubek <lzoubek@redhat.com>
Date:   Thu Sep 4 16:35:31 2014 +0200

    Bug 1136079 - 'Red Hat Access' fails to attach JDR report to new case if JON
    is under proxy
    
    also bump support-lib userAgent string to 2.0.5

Comment 3 Simeon Pinder 2014-09-17 02:49:43 UTC
Moving to ON_QA as available for test with the following brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=385149

Comment 4 Jeeva Kandasamy 2014-09-23 11:18:17 UTC
Verified with JDR report. 

Version:
JBoss Operations Network
Version : 3.3.0.ER03
Build Number : 4aefe39:44e33a4
GWT Version : 2.5.0
SmartGWT Version : 3.0p


Note You need to log in before you can comment on or make changes to this bug.