Bug 1136223 - [abrt] dnf: packages.py:76:parsePackages:TypeError: unsupported operand type(s) for |=: 'set' and 'list'
[abrt] dnf: packages.py:76:parsePackages:TypeError: unsupported operand type(...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
21
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Honza Silhan
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:63571619b1c8cd571ce259c5e4f...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-09-02 04:10 EDT by Nils Philippsen
Modified: 2015-10-13 02:53 EDT (History)
5 users (show)

See Also:
Fixed In Version: dnf-0.6.2 dnf-0.6.4-7.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-13 02:53:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (2.59 KB, text/plain)
2014-09-02 04:10 EDT, Nils Philippsen
no flags Details
File: environ (3.64 KB, text/plain)
2014-09-02 04:10 EDT, Nils Philippsen
no flags Details

  None (edit)
Description Nils Philippsen 2014-09-02 04:10:28 EDT
Description of problem:
root@gibraltar:~> dnf history info NetworkManager
Failed to synchronize cache for repo 'fedora-chromium-stable' from '[u'http://repos.fedorapeople.org/repos/spot/chromium-stable/fedora-21/x86_64/']': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried, disabling.
Transaction ID : 286
Begin time     : Tue Sep  2 10:07:32 2014
Begin rpmdb    : 5342:9b49cb4f1924cda96212d3049e7d34d37e50e7db
End time       :            10:07:44 2014 (12 seconds)
End rpmdb      : 5343:ad4803a71bc8cdc97f36a9da7c7a58f973ac5783
User           : Nils Philippsen <nils>
Return-Code    : Success
Command Line   : update --exclude=httpd
Transaction performed with:
    Installed     dnf-0.6.0-1.fc21.noarch        @fedora
    Installed     rpm-4.12.0-0.rc1.1.fc21.x86_64 @fedora
Packages Altered:
Traceback (most recent call last):
  File "/bin/dnf", line 36, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 182, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 134, in _main
    cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1072, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python2.7/site-packages/dnf/cli/commands/__init__.py", line 1232, in run
    ret = self.output.historyInfoCmd(extcmds)
  File "/usr/lib/python2.7/site-packages/dnf/cli/output.py", line 1474, in historyInfoCmd
    self._historyInfoCmd(tid, pats)
  File "/usr/lib/python2.7/site-packages/dnf/cli/output.py", line 1612, in _historyInfoCmd
    self.historyInfoCmdPkgsAltered(old, pats)
  File "/usr/lib/python2.7/site-packages/dnf/cli/output.py", line 1687, in historyInfoCmdPkgsAltered
    x, m, u = dnf.yum.packages.parsePackages([hpkg], pats)
  File "/usr/lib/python2.7/site-packages/dnf/yum/packages.py", line 76, in parsePackages
    exactmatch |= pkgdict[command]
TypeError: unsupported operand type(s) for |=: 'set' and 'list'
root@gibraltar:~>

Version-Release number of selected component:
dnf-0.6.0-1.fc21

Additional info:
reporter:       libreport-2.2.3
cmdline:        /usr/bin/python -OO /bin/dnf history info NetworkManager
executable:     /bin/dnf
kernel:         3.16.1-301.fc21.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
packages.py:76:parsePackages:TypeError: unsupported operand type(s) for |=: 'set' and 'list'

Traceback (most recent call last):
  File "/bin/dnf", line 36, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 182, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 134, in _main
    cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1072, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python2.7/site-packages/dnf/cli/commands/__init__.py", line 1232, in run
    ret = self.output.historyInfoCmd(extcmds)
  File "/usr/lib/python2.7/site-packages/dnf/cli/output.py", line 1474, in historyInfoCmd
    self._historyInfoCmd(tid, pats)
  File "/usr/lib/python2.7/site-packages/dnf/cli/output.py", line 1612, in _historyInfoCmd
    self.historyInfoCmdPkgsAltered(old, pats)
  File "/usr/lib/python2.7/site-packages/dnf/cli/output.py", line 1687, in historyInfoCmdPkgsAltered
    x, m, u = dnf.yum.packages.parsePackages([hpkg], pats)
  File "/usr/lib/python2.7/site-packages/dnf/yum/packages.py", line 76, in parsePackages
    exactmatch |= pkgdict[command]
TypeError: unsupported operand type(s) for |=: 'set' and 'list'

Local variables in innermost frame:
pkgdict: {u'networkmanager-0.9.10.0-4.git20140704.fc21.x86_64': [<YumHistoryPackageState : 1:NetworkManager-0.9.10.0-4.git20140704.fc21.x86_64 (0x7f08eb70aa50)>], u'networkmanager.x86_64': [<YumHistoryPackageState : 1:NetworkManager-0.9.10.0-4.git20140704.fc21.x86_64 (0x7f08eb70aa50)>], u'networkmanager-0.9.10.0-4.git20140704.fc21': [<YumHistoryPackageState : 1:NetworkManager-0.9.10.0-4.git20140704.fc21.x86_64 (0x7f08eb70aa50)>], u'1:networkmanager-0.9.10.0-4.git20140704.fc21.x86_64': [<YumHistoryPackageState : 1:NetworkManager-0.9.10.0-4.git20140704.fc21.x86_64 (0x7f08eb70aa50)>], u'networkmanager-0.9.10.0': [<YumHistoryPackageState : 1:NetworkManager-0.9.10.0-4.git20140704.fc21.x86_64 (0x7f08eb70aa50)>], u'networkmanager-1:0.9.10.0-4.git20140704.fc21.x86_64': [<YumHistoryPackageState : 1:NetworkManager-0.9.10.0-4.git20140704.fc21.x86_64 (0x7f08eb70aa50)>], u'networkmanager': [<YumHistoryPackageState : 1:NetworkManager-0.9.10.0-4.git20140704.fc21.x86_64 (0x7f08eb70aa50)>]}
pkgs: [<YumHistoryPackageState : 1:NetworkManager-0.9.10.0-4.git20140704.fc21.x86_64 (0x7f08eb70aa50)>]
exactmatch: set([])
command: u'networkmanager'
unmatched: set([])
usercommands: [u'NetworkManager']
casematch: 0
matched: set([])
Comment 1 Nils Philippsen 2014-09-02 04:10:32 EDT
Created attachment 933621 [details]
File: backtrace
Comment 2 Nils Philippsen 2014-09-02 04:10:33 EDT
Created attachment 933622 [details]
File: environ
Comment 3 Honza Silhan 2014-09-03 06:27:30 EDT
Hi, thanks for the report.
Comment 4 Honza Silhan 2014-09-05 06:52:25 EDT
Fixed in the upstream.
Comment 5 Nils Philippsen 2014-09-09 10:34:32 EDT
Hi Jan, do you plan to submit this version as an update for F-21?
Comment 6 Honza Silhan 2014-09-10 06:40:26 EDT
Hi, dnf-0.6.2 release with f21 update will be in a week or so. If you are impatient you can install nightly build.
Comment 7 Nils Philippsen 2014-09-10 07:24:27 EDT
Ahh, I misunderstood this:

> Fixed In Version: dnf-0.6.2

to mean that 0.6.2 were released already.
Comment 8 Parag Nemade 2014-09-10 09:14:01 EDT
I too used to confuse with what dnf developers are following but now used to with it. My understanding is that when you fix package (checkin fixes in dist-git of dnf package and build a new package on koji) you should change the bug status to MODIFIED and add built n-v-r in "Fixed In version" field.
Comment 9 Nils Philippsen 2014-09-10 09:25:19 EDT
Not so sure about manually setting the "Fixed in version" field, as bodhi does it automatically when pushing updates to stable.
Comment 10 Fedora Update System 2014-10-05 13:42:05 EDT
dnf-0.6.2-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/dnf-0.6.2-1.fc21
Comment 11 Fedora Update System 2014-10-06 01:03:42 EDT
Package dnf-0.6.2-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-0.6.2-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-12254/dnf-0.6.2-1.fc21
then log in and leave karma (feedback).
Comment 12 Honza Silhan 2015-07-20 07:14:54 EDT
wasn't properly closed by Fedora Update System.
Comment 13 Fedora Update System 2015-08-28 14:53:48 EDT
dnf-0.6.4-6.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update dnf'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14323
Comment 14 Fedora Update System 2015-09-29 07:19:37 EDT
dnf-0.6.4-7.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-9bcdcdc46b
Comment 15 Fedora Update System 2015-10-02 14:52:26 EDT
dnf-0.6.4-7.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update dnf'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-9bcdcdc46b
Comment 16 Fedora Update System 2015-10-13 02:52:24 EDT
dnf-0.6.4-7.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.