Bug 113639 - Autorun causes blinking hard drive light
Autorun causes blinking hard drive light
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: autorun (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-15 20:04 EST by Karl Herrick
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-30 06:56:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Karl Herrick 2004-01-15 20:04:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
Currently, as my computer sits in KDE my hard drive
light will come on... come off... come on... come off. It is in
regular intervals and stays lit for only 1/2 a second, and then waits
2 seconds and comes on again. I have no programs running, and the
screensaver is even off. The system monitor shows nothing running, and
I have shut down all of my daemons. I had Redhat 9 installed and then
switched to Fedora, but I am finding no relief from this problem.
These are fresh installs after I installed all of the updates to each
of the OSes... has anyone else had this problem... or does anyone know
how to fix it?

Version-Release number of selected component (if applicable):
autorun-3.11-1

How reproducible:
Always

Steps to Reproduce:
1. install Redhat 9 update with YUM or
2. do a fresh install of Fedora core 1
3.
    

Actual Results:  hard drive blinks ever 2 seconds continuously forever
when logged into KDE... magicdev causes the same problem in Gnome.

Additional info:

Motherboard: Asus P4PE
CPU: Pentium-4 2.4ghz 512k cache
Memory: 512 mb pc2700
Hard Drive: 40gb... I think it is 100m/s
CDRW: LITE-ON 52x24x52x

Other people are having these same problems with similar setups:
http://www.linuxquestions.org/questions/archive/5/2002/11/3/35989
http://club.cdfreaks.com/showthread/t-61346.html

The magicdev bug is similar and needs to be fixed. It only loads up
with Gnome in FC1, and causes the hard drive light to flash. In KDE
this problem is caused by Autorun. If I don't shut these off when in
one or the other my hard drive blinks continuously forever.
Comment 1 Karl Herrick 2004-01-15 21:59:07 EST
I pulled the LITE-ON cdrw drive out, and put in a different one, and
the blinking stopped... something to do with Autorun, and Magicdev.

Once again, the only way to get the hard drive light to shut off, is
to kill Autorun in KDE, or Magicdev in Gnome... or remove the LITE-ON
cdrw drive. I think these two processes need to be patched.
Comment 2 Harald Hoyer 2004-01-29 05:14:05 EST
if you don't want it, deinstall the apps that cause your blinking:
# rpm -e autorun magicdev

Comment 3 Karl Herrick 2004-01-29 09:40:53 EST
Uninstalling a program is not the answer to a problem with code. This
should be fixed as it causes the hard drive to run incessantly.
Comment 4 Harald Hoyer 2004-01-29 09:56:21 EST
hard drive or cdrom?
does it blink, though it has a medium in it?
Comment 5 Karl Herrick 2004-01-29 09:59:37 EST
The hard drive blinks whether it has a cd in the tray or not. There
are three ways to fix this.

Fixing the code or..
Removing the Lite-on cd drive or..
Uninstalling Magicdev or Autorun.

Btw, I am not flaming against Redhat/Fedora... but whatever processes
Mandrake and Knoppix use to auto load cd's... it works, because the
same problem doesn't happen with those distro's on the same hardware.
Comment 6 Harald Hoyer 2004-01-29 10:07:07 EST
hmm... I'll take a look into Mandrake and Knoppix.. thx!
Comment 7 Harald Hoyer 2004-08-30 06:56:56 EDT
ok, the approach Mandrake and Knoppix have, is over automount. this
cannot be done with autorun. sorry

Note You need to log in before you can comment on or make changes to this bug.