Bug 1136487 - Octave 3.8 support for swig
Summary: Octave 3.8 support for swig
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: swig   
(Show other bugs)
Version: 7.0
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Jitka Plesnikova
QA Contact: Martin Cermak
Tomas Capek
URL:
Whiteboard:
Keywords: EasyFix, FutureFeature, Patch
Depends On:
Blocks: 1191019 1289025 1305230
TreeView+ depends on / blocked
 
Reported: 2014-09-02 17:15 UTC by Orion Poplawski
Modified: 2016-11-04 01:05 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Release Note
Doc Text:
Support for Octave 3.8 used by _swig_ Previously, the Octave code generated by *swig* 2.0.10 did not work with Octave 3.8, because it contained deprecated bits such as variables and macros. This update ensures that *swig* produces code which works with Octave of versions 3.0.5, 3.2.4, 3.4.3, 3.6.4, and 3.8.0.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 01:05:15 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for support Octave 3.8.0 (10.80 KB, patch)
2014-09-03 10:45 UTC, Jitka Plesnikova
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2227 normal SHIPPED_LIVE swig bug fix and enhancement update 2016-11-03 13:26:40 UTC

Description Orion Poplawski 2014-09-02 17:15:51 UTC
Description of problem:

swig 2.0.10 does not produce appropriate code for octave 3.8 (now in EPEL).  swig 3.0.0 has support via this commit https://github.com/swig/swig/commit/5b167cc12daf9ea275c17fedaefc975450613ab2.patch which probably could be backported fairly easily.

Version-Release number of selected component (if applicable):
2.0.10-4.el7

Comment 2 Jitka Plesnikova 2014-09-03 10:21:45 UTC
I can update the swig, but I am not able to check it properly for octave 3.8.0.
The build tests don't cover octave, because it isn't part of RHEL.

If you want to check it, you can use rpms at 
https://jplesnik.fedorapeople.org/swig-octave-3.8.0/

Comment 3 Jitka Plesnikova 2014-09-03 10:45:26 UTC
Created attachment 934039 [details]
Patch for support Octave 3.8.0

Comment 4 Orion Poplawski 2014-09-03 15:57:24 UTC
Jitka - Wow, that might be the quickest response I have ever received to a RHEL bug.  Thanks!

I built plplot with octave support just fine with your patched swig package, so that did the trick.  Thanks again.  Now I'm sorry I didn't file it back in January.

Comment 5 Jitka Plesnikova 2014-09-04 05:55:25 UTC
I cannot promise that the fix will be at RHEL 7.1.

Please contact Red Hat Product Support ( access.redhat.com ) - this can increase the chances for next minor release.

Comment 8 Jitka Plesnikova 2016-03-16 11:33:14 UTC
For tests I did:
* install octave-devel from EPEL 7 repository
* install all BRs (autoconf, automake, boost-devel, dos2unix, gawk, guile-devel, 
    pcre-devel, perl, perl(Test::More), perl-devel, python-devel, tcl-devel)
* rebuild source RPM, 
rpmbuild --rebuild swig-2.0.10-5.el7.src.rpm

Octave tests passed

Comment 15 errata-xmlrpc 2016-11-04 01:05:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2227.html


Note You need to log in before you can comment on or make changes to this bug.