Bug 1136498 - The new update of flare does not put any mod, and without any mod we can't play the game
Summary: The new update of flare does not put any mod, and without any mod we can't pl...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: flare
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Erik Schilling
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-02 17:37 UTC by Marcos Paulo
Modified: 2014-09-02 18:25 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-02 17:41:42 UTC
Type: Bug


Attachments (Terms of Use)
The game menu with the Play Game menu disabled. (18.92 KB, application/octet-stream)
2014-09-02 17:37 UTC, Marcos Paulo
no flags Details

Description Marcos Paulo 2014-09-02 17:37:05 UTC
Created attachment 933880 [details]
The game menu with the Play Game menu disabled.

Description of problem: The user can't play the game because any module is within the package


Version-Release number of selected component (if applicable):


How reproducible: Execute the flare game


Steps to Reproduce:
1. The "Play Game" button is disabled an tells the user to enable a core mod
2. Click "Configuration" button and go to Mod tabpage
3. There isn't any modules available

Actual results: The user can't play the flare game of the repository


Expected results: the user should be able to play the game


Additional info:

Comment 1 Erik Schilling 2014-09-02 17:41:42 UTC
This looks like you simply execute "flare" from the terminal or however.
Please make sure to execute it either using an ui launcher (so via the flare.desktop) or via the command /usr/bin/flare "--game=flare-game".

The new flare installs its mods into a subdirectory which has to be selected to allow multiple different sets of mods.

While this is confusing for old users this was an upstream decision, so there is nothing I can do about it.

Please Reopen the issue if the explanation i gave does not match to your issue.

Regards,
Erik

Comment 2 Marcos Paulo 2014-09-02 17:44:57 UTC
I executed by terminal because the flare menu icon of the Mate (Applications->Games->Flare) was removed after this update.

How, when I tried "/usr/bin/flare "--game=flare-game"" this worked. Thanks!

But, what about the Mate menu entry of flare, any idea why this was removed?

Comment 3 Erik Schilling 2014-09-02 18:25:13 UTC
right... I just realized that the .desktop file somehow does not show up here anymore too...

Unfortunatly I won't have time to look into this before the weekend. But I opened a bug for tracking: https://bugzilla.redhat.com/show_bug.cgi?id=1136515

Feel free to follow that for progress.

Thanks for reporting, Have fun playing!

Regards,
Erik


Note You need to log in before you can comment on or make changes to this bug.