Bug 1136580 - Missing groups causing rawhide not to boot
Summary: Missing groups causing rawhide not to boot
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openobex
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tomáš Hozza
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-02 23:21 UTC by Daniel Walsh
Modified: 2014-10-16 01:59 UTC (History)
9 users (show)

Fixed In Version: openobex-1.7.1-5.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-01 12:46:10 UTC
Type: Bug


Attachments (Terms of Use)

Description Daniel Walsh 2014-09-02 23:21:19 UTC

Comment 1 Daniel Walsh 2014-09-02 23:22:31 UTC
I had to add the following groups to get rawhide to boot.

systemd-journal-remote:x:203:
plugdev:x:202

Most likely problem with new method of setting up /etc/group from scratch.

Comment 2 Zbigniew Jędrzejewski-Szmek 2014-09-02 23:31:49 UTC
systemd version? What packages?

Comment 3 Daniel Walsh 2014-09-03 09:27:36 UTC
 rpm -q systemd
systemd-216-3.fc22.x86_64

Comment 4 Zbigniew Jędrzejewski-Szmek 2014-09-04 05:08:50 UTC
Some tmpfiles.d and sysusers.d config was placed in the main package instead of systemd-journal-gateway by mistake. This is sorted out in systemd-216-4.fc22.
%preinst scripts create the users, so 'systemd-journal-remote' should be created for packages which reference it. I wouldn't think that this change matters, but should be done for correctness anyway.

As for 'plugdev', this string does not appear in systemd sources, and grepping a rawhide installation, I see it only in comments. What kind of errors are you seeing, and what files use 'plugdev'?

Comment 5 Daniel Walsh 2014-09-06 13:26:52 UTC
Sep 02 09:20:37 redsox.boston.devel.redhat.com systemd-udevd[13981]: specified group 'plugdev' unknown
Sep 02 09:24:50 redsox.boston.devel.redhat.com systemd-udevd[13981]: specified group 'plugdev' unknown
Sep 02 09:26:39 redsox.boston.devel.redhat.com systemd-udevd[13981]: specified group 'plugdev' unknown
Sep 02 09:27:45 redsox.boston.devel.redhat.com systemd-udevd[13981]: specified group 'plugdev' unknown
Sep 02 09:29:16 redsox.boston.devel.redhat.com systemd-udevd[13981]: specified group 'plugdev' unknown
Sep 02 09:30:39 redsox.boston.devel.redhat.com systemd-udevd[13981]: specified group 'plugdev' unknown
Sep 02 09:33:12 redsox.boston.devel.redhat.com systemd-udevd[13981]: specified group 'plugdev' unknown

Comment 6 Zbigniew Jędrzejewski-Szmek 2014-09-06 13:55:48 UTC
What does 'grep plugdev -r /usr/lib/udev/rules.d /etc/udev/rules.d' say?
Also, if there are any hits, can you say from which rpms are those files?

Comment 7 Daniel Walsh 2014-09-09 21:10:37 UTC
grep plugdev -r /usr/lib/udev/rules.d /etc/udev/rules.d
/usr/lib/udev/rules.d/60-openobex.rules:ACTION=="add", SUBSYSTEM=="usb", PROGRAM="/usr/sbin/obex-check-device $attr{idVendor} $attr{idProduct}", MODE="660", GROUP="plugdev"
sh-4.3# rpm -qf /usr/lib/udev/rules.d/60-openobex.rules
openobex-1.7.1-4.fc22.x86_64

Comment 8 Zbigniew Jędrzejewski-Szmek 2014-09-23 01:56:18 UTC
Fedora does not use 'plugdev' group (see e.g. [1] for some discussion). In the case of openobex the solution is mostly likely to tag the devices with 
ENV{ID_MEDIA_PLAYER}=..., which will make them accessible to logged in users.

[1] https://bugzilla.redhat.com/show_bug.cgi?id=859244#c16

Comment 9 Tomáš Hozza 2014-10-01 11:48:51 UTC
(In reply to Daniel Walsh from comment #5)
> Sep 02 09:20:37 redsox.boston.devel.redhat.com systemd-udevd[13981]:
> specified group 'plugdev' unknown
> Sep 02 09:24:50 redsox.boston.devel.redhat.com systemd-udevd[13981]:
> specified group 'plugdev' unknown
> Sep 02 09:26:39 redsox.boston.devel.redhat.com systemd-udevd[13981]:
> specified group 'plugdev' unknown
> Sep 02 09:27:45 redsox.boston.devel.redhat.com systemd-udevd[13981]:
> specified group 'plugdev' unknown
> Sep 02 09:29:16 redsox.boston.devel.redhat.com systemd-udevd[13981]:
> specified group 'plugdev' unknown
> Sep 02 09:30:39 redsox.boston.devel.redhat.com systemd-udevd[13981]:
> specified group 'plugdev' unknown
> Sep 02 09:33:12 redsox.boston.devel.redhat.com systemd-udevd[13981]:
> specified group 'plugdev' unknown

I can see the error in log, however if I install openobex on rawhide,
the system boots up successfully. Thank you for the report, I will
fix the udev rule distributed by openobex.

The failing boot is most probably caused by something else.

Comment 10 Fedora Update System 2014-10-01 12:45:36 UTC
openobex-1.7.1-5.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/openobex-1.7.1-5.fc21

Comment 11 Tomáš Hozza 2014-10-01 12:46:10 UTC
Fixed in:
openobex-1.7.1-5.fc21
openobex-1.7.1-5.fc22

Comment 12 Fedora Update System 2014-10-16 01:59:11 UTC
openobex-1.7.1-5.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.