Bug 1136602 - [whql][netkvm]Guest (64 bits Operating System) got BSOD (DRIVER_VERIFIER_DETECTED_VIOLATION) while run some jobs
Summary: [whql][netkvm]Guest (64 bits Operating System) got BSOD (DRIVER_VERIFIER_DETE...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Yan Vugenfirer
QA Contact: Virtualization Bugs
URL:
Whiteboard: Fixed_Not_Ship
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-03 02:13 UTC by Min Deng
Modified: 2015-11-24 08:43 UTC (History)
11 users (show)

Fixed In Version: virtio-win-prewhql-0.1-101
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Clone Of:
Environment:
Last Closed: 2015-11-24 08:43:40 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot (30.55 KB, application/octet-stream)
2014-09-03 02:13 UTC, Min Deng
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2513 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2015-11-24 13:38:38 UTC

Description Min Deng 2014-09-03 02:13:55 UTC
Created attachment 933923 [details]
Screenshot

Description of problem:
Guest got BSOD (DRIVER_VERIFIER_DETECTED_VIOLATION) while run some jobs

Version-Release number of selected component (if applicable):
virtio-win-prewhql-0.1-91
qemu-kvm-rhev-debuginfo-2.1.0-2.el7.x86_64
qemu-kvm-rhev-2.1.0-2.el7.x86_64
How reproducible:
5/5

Steps to Reproduce:
1.boot up guest with the following cli,
  /usr/libexec/qemu-kvm -name 091NICBLUE64CMA -enable-kvm -m 6G -smp 4 -uuid cfc83383-b4c8-46bd-9fa5-cf20cfb960e9 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/tmp/091NICBLUE64CMA,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=091NICBLUE64CMA,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_8_1_enterprise_x64_dvd_2971902.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=091NICBLUE64CMA.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:5d:05:e5:69,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:2 -vga cirrus -netdev tap,script=/etc/qemu-ifup-private,downscript=no,id=hostnet1,vhost=on -device virtio-net-pci,netdev=hostnet1,id=net1,mac=00:52:06:2d:f0:b6,bus=pci.0,mq=on
root     31358  8.8 19.3 7070112 6322324 ?     Sl   Sep02 101:08 /usr/libexec/qemu-kvm -name 091NICBLUE64SMA -enable-kvm -m 6G -smp 4 -uuid 97aeb3b0-a0b3-408f-87bb-c31a2d1f66f5 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/tmp/091NICBLUE64SMA,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=091NICBLUE64SMA,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_8_1_enterprise_x64_dvd_2971902.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=091NICBLUE64SMA.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:47:55:c8:74,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:3 -vga cirrus -netdev tap,script=/etc/qemu-ifup-private,downscript=no,id=hostnet1,vhost=on -device virtio-net-pci,netdev=hostnet1,id=net1,mac=00:52:20:4e:ae:7e,bus=pci.0,mq=on
2.submit jobs
  For example,
  DF - Concurrent Hardware And Operating System (CHAOS) Test (Certification)
  DF - Fuzz Query and Set File Information Test (Certification)
  
3.The guest always got BSOD with issue  (DRIVER_VERIFIER_DETECTED_VIOLATION)

Actual results:
The guest got bsod almost for all 64 bits Operating System
win2012,win2012R2,win81-64

Expected results:
The job could pass on those guests

Additional info:
Screen shot and dump file will upload to the bug.

Comment 3 Min Deng 2014-09-03 02:47:26 UTC
Dump file,
\\smamit.eng.lab.tlv.redhat.com\win-team\Public\QE\1136602
smb/smb

Comment 7 Yossi Hindin 2014-09-16 13:25:02 UTC

*** This bug has been marked as a duplicate of bug 1136606 ***

Comment 8 Min Deng 2014-09-23 05:41:11 UTC
(In reply to Yossi Hindin from comment #7)
> 
> *** This bug has been marked as a duplicate of bug 1136606 ***

Re-open it as the the code bsod is different with 1136606 and the same issue still could be reproduced via build 92.Any issues please let me know,thanks.

Thanks
Min

Comment 9 Min Deng 2014-09-23 05:44:27 UTC
(In reply to dengmin from comment #8)
> (In reply to Yossi Hindin from comment #7)
> > 
> > *** This bug has been marked as a duplicate of bug 1136606 ***
> 
> Re-open it as the the code bsod is different with 1136606 and the same issue
> still could be reproduced via build 92.Any issues please let me know,thanks.
> 
> Thanks
> Min

 The related job is - 1784 NDISTest 6.0 - [1 Machine] - 1c_FaultHandling.

Comment 11 Yossi Hindin 2015-01-15 10:00:33 UTC
Please, test this bug usinh build virtio-win-prewhql-0.1-100

Comment 13 lijin 2015-02-03 07:24:42 UTC
retest with build 100,win8-64/win8.1-64/win2012/win2012R2 guests still BSOD when run job "NDISTest 6.0 - [1 Machine] - 1c_FaultHandling"
check guest network after reboot,found virtio-net was disabled,and guest will BSOD when enable the virtio-net.

package info:
    virtio-win-prewhql-0.1-100
    qemu-kvm-rhev-2.1.2-20.el7.x86_64
    kernel-3.10.0-223.el7.x86_64
    seabios-1.7.5-7.el7.x86_64
    spice-server-0.12.4-9.el7.x86_64

Comment 15 Mike Cao 2015-02-03 07:32:11 UTC
Re-assgined this issue according to comment #13.

Comment 16 Vadim Rozenfeld 2015-03-03 02:46:26 UTC
Should be fixed in build 101, available at http://download.devel.redhat.com/brewroot/packages/virtio-win-prewhql/0.1/101/win/virtio-win-prewhql-0.1.zip

Comment 17 lijin 2015-03-10 05:21:17 UTC
job can pass with build 101

Comment 20 lijin 2015-07-17 07:09:12 UTC
change status to verified according to comment#11

Comment 22 errata-xmlrpc 2015-11-24 08:43:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2513.html


Note You need to log in before you can comment on or make changes to this bug.