Bug 113672 - fr-latin9 aliased to fr-latin0
fr-latin9 aliased to fr-latin0
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: rhpl (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-16 07:16 EST by Nicolas Mailhot
Modified: 2007-04-18 13:01 EDT (History)
0 users

See Also:
Fixed In Version: 1.12-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-09 21:47:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2004-01-16 07:16:08 EST
Following bug #88324 fr-latin9 was aliased to fr-latin0

This is not the way to go. fr-latin9 is present in both kbd and
XFree86 now (unlike fr-latin0) so the correct fix is to make redhat
tools aware of it.

Historically when I asked here about merging upstream fr-latin0 fixes
in RH kbd and putting the matching map in XFree86 I was answered to
merge the maps upstream first. Well I did it - got to the external
fr-latin0 site, took the latest maps, cleaned them up and went through
the lenghty procedure to get them merged in kbd and in XFree86 (this
was before XFree86 opend up its procedures).

Upstream maps had been renamed latin9 since that's the real name of
the latin0 standard, so that's how they ended up both in XFree86 and kbd.

Now I'd really like RedHat to acknowledge the changes and update its
keyboard maps so the matching XFree86 map is selected when fr-latin9
is selected by the user. I've asked for this on a separate report
years ago. Having RH still use
fr-latin0 = fr-latin0 (kbd) + fr (XFree86)
instead of
fr-latin9 = fr-latin9 (kdb) + fr-latin9 (XFree86)
after all the work I put into this (as requested by RH people on this
bugzilla) makes me a little mad.
Comment 1 Eido Inoue 2004-02-27 17:25:59 EST
we now use kbd-1.12, which should pull the changes from upstream. the
alias creation via copies is still there for compatibility, though.
Comment 2 Nicolas Mailhot 2004-02-28 08:13:13 EST
[root@rousalka nim]# system-config-keyboard
Loading /lib/kbd/keymaps/i386/azerty/fr-latin0.map.gz
assuming iso-8859-1 cedilla
assuming iso-8859-1 acute
assuming iso-8859-1 diaeresis
assuming iso-8859-1 brokenbar
assuming iso-8859-1 threequarters
assuming iso-8859-1 currency
assuming iso-8859-1 onehalf
assuming iso-8859-1 onequarter
* running ['/usr/X11R6/bin/setxkbmap', '-layout', 'fr', '-model',
'pc105', '-option', '']

[nim@rousalka]~% rpm -q system-config-keyboard kbd XFree86
system-config-keyboard-1.2.1-1.1
kbd-1.12-1
XFree86-4.3.0-60

1. fr-latin9 still does not appear in the keyboard list
2. when selecting fr-latin0, fr-latin9 is still not selected in XF86Config

Adding an alias is ok. Using it to avoid adding the kbd + XFree86
fr-latin9 combo to the system tools list is not
Comment 4 Brent Fox 2004-03-05 10:47:54 EST
Nicolas: The list of keyboards comes from keyboard_models.py in the
rhpl package, so I'm changing the component to rhpl.

Also, I've changed our keyboard model list from fr-latin0 to
fr-latin9.  Instead of seeing an entry in the keyboard list for
"French (latin0)", you will now see "French (latin9)" and the
fr-latin9 keymap will be loaded instead of fr-latin0.

I believe that this should fix the issue, but please reopen this bug
if it does not.  The fix should appear in rhpl-0.132-1.  Thanks for
working with us on this issue.
Comment 5 Nicolas Mailhot 2004-03-05 11:18:20 EST
Thank you very much for the change.
I'll wait eagerly for the update
Comment 6 Nicolas Mailhot 2004-03-06 10:49:07 EST
Got rhpl-0.132-1, the change is there all right

Unfortunately I have to reopen the bug since system-config-keyboard
still thinks it should select fr for XF86Config when the user chooses
fr-latin9

Again the main difference between fr-latin0 and fr-latin9 (appart from
the name change and a few fixes) is that fr-latin9 was/is integrated
in XFree86 (unlike fr-latin0), so intead of selecting fr-latinx for
the console and plain fr for XFree86 one can and should select the
matching map in XFree86
Comment 7 Brent Fox 2004-03-09 21:47:15 EST
Oops, I changed the kbd keymap to fr-latin9 but not the X keymap. 
Should be fixed in rhpl-0.134-1.
Comment 8 Nicolas Mailhot 2004-03-10 16:57:48 EST
I can confirm it's working now
Thanks a lot for your time
Comment 9 Brent Fox 2004-03-10 17:06:58 EST
Thanks for bringing this to our attention.

Note You need to log in before you can comment on or make changes to this bug.