Bug 1136745 - perl-Convert-PEM-0.08-13.fc22 FTBFS randomly: 'errstr matches decrypt failed' t/02-encode.t test fails
Summary: perl-Convert-PEM-0.08-13.fc22 FTBFS randomly: 'errstr matches decrypt failed'...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-Convert-PEM
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-03 08:33 UTC by Petr Pisar
Modified: 2021-07-14 01:30 UTC (History)
3 users (show)

Fixed In Version: perl-Convert-PEM-0.08-14.fc22 perl-Convert-PEM-0.08-14.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-05 10:37:29 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
CPAN 27574 0 None None None Never

Description Petr Pisar 2014-09-03 08:33:24 UTC
perl-Convert-PEM-0.08-13.fc22 fails to build randomly in F22 because 'errstr matches decrypt failed' t/02-encode.t test sometimes fails:

#   Failed test 'errstr matches decrypt failed'
#   at t/02-encode.t line 28.
#                   'ASN decode failed: decode error at /usr/share/perl5/vendor_perl/Convert/ASN1/_decode.pm line 64.
# '
#     doesn't match '(?^:^Decryption failed)'
# Looks like you failed 1 test of 9.
t/02-encode.t ..... 
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/9 subtests 

You can reproduce it with this command:

Convert-PEM-0.08$ while (prove -b -v t/02-encode.t); do :; done

Comment 1 Fedora Update System 2021-06-28 13:24:02 UTC
FEDORA-EPEL-2021-976a98491a has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-976a98491a

Comment 2 Fedora Update System 2021-06-29 01:28:39 UTC
FEDORA-EPEL-2021-976a98491a has been pushed to the Fedora EPEL 7 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-976a98491a

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 3 Fedora Update System 2021-07-14 01:30:13 UTC
FEDORA-EPEL-2021-976a98491a has been pushed to the Fedora EPEL 7 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.