Bug 1136833 - Hides submit button with gtk+ 2.24
Summary: Hides submit button with gtk+ 2.24
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: system-config-keyboard
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Nils Philippsen
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-03 12:02 UTC by Branislav Blaškovič
Modified: 2014-10-14 08:30 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Previous versions of gtk2 had a horizontal separator between the dialog contents and the buttons. The system-config-keyboard program attempted to remove that widget, but did so in a very crude fashion. Consequence: With the rebase of gtk2 to 2.24.23, dialog window widgets don't have an horizontal separator above their buttons. Because system-config-keyboard relies on the inner structure of the dialog window to find the separator widget and because it lacked additional checks, with this new version of gtk2 the OK button was removed instead. Fix: This new release of system-config-keyboard checks that the widget it would delete is actually a horizontal separator, otherwise it does nothing. Result: The OK button remains and no horizontal separator is shown, regardless of if the older or current versions of the gtk2 package are installed.
Clone Of:
Environment:
Last Closed: 2014-10-14 08:30:51 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot of missing submit button (1.44 MB, application/octet-stream)
2014-09-03 12:04 UTC, Branislav Blaškovič
no flags Details
Proposed patch (1.08 KB, patch)
2014-09-08 13:50 UTC, Nils Philippsen
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1100886 0 unspecified CLOSED rebase gtk2 to the current 2.24.x release 2021-02-22 00:41:40 UTC
Red Hat Product Errata RHBA-2014:1617 0 normal SHIPPED_LIVE system-config-keyboard bug fix update 2014-10-14 01:39:16 UTC

Internal Links: 1100886

Description Branislav Blaškovič 2014-09-03 12:02:29 UTC
Description of problem:
I cannot see submit button for dialog.

Version-Release number of selected component (if applicable):
system-config-keyboard-1.3.1-5.el6.x86_64

Steps to Reproduce:
1. Run system-config-keyboard
2. Try to submit it

Actual results:
No submit button

Expected results:
Submit button

Comment 1 Branislav Blaškovič 2014-09-03 12:04:52 UTC
Created attachment 934054 [details]
Screenshot of missing submit button

Comment 3 Petr Sklenar 2014-09-03 12:41:26 UTC
it seems to be regression, I can see it in my rhel65 with system-config-keyboard-1.3.1-4.el6.x86_64

Comment 5 Nils Philippsen 2014-09-03 15:09:18 UTC
(In reply to Petr Sklenar from comment #3)
> it seems to be regression, I can see it in my rhel65 with
> system-config-keyboard-1.3.1-4.el6.x86_64

Petr, have you checked -5 as well? This release of the package is available since before RHEL 6.5 FWIW.

I have just run it on an up-to-date RHEL6.5 and it displays well. Removing the Regression keyword for now.

Branislav, if you start s-c-keyboard from a terminal, do you see any error messages?

Comment 7 Branislav Blaškovič 2014-09-04 08:14:06 UTC
(In reply to Nils Philippsen from comment #5)
> I have just run it on an up-to-date RHEL6.5 and it displays well. Removing
> the Regression keyword for now.
So, it is OK in rhel6.5 but broken on rhel6.6 so it is NOT a regression? I assume that if it is working on older version but not working on newer one, it is regression. But maybe I just dont understand it :)

> Branislav, if you start s-c-keyboard from a terminal, do you see any error
> messages?
Nothing on terminal..

Comment 8 Petr Sklenar 2014-09-05 07:53:43 UTC
(In reply to Petr Sklenar from comment #3)
> it seems to be regression, I can see it in my rhel65 with
> system-config-keyboard-1.3.1-4.el6.x86_64
with that it I meant "submit button" not 'the bug'

so 
system-config-keyboard-1.3.1-4.el6.x86_64 : there is "submit button"
system-config-keyboard-1.3.1-5.el6.x86_64: there is not submit button, this version is buggy

Comment 10 Nils Philippsen 2014-09-08 13:47:51 UTC
(In reply to Petr Sklenar from comment #8)
> (In reply to Petr Sklenar from comment #3)
> > it seems to be regression, I can see it in my rhel65 with
> > system-config-keyboard-1.3.1-4.el6.x86_64
> with that it I meant "submit button" not 'the bug'
> 
> so 
> system-config-keyboard-1.3.1-4.el6.x86_64 : there is "submit button"
> system-config-keyboard-1.3.1-5.el6.x86_64: there is not submit button, this
> version is buggy

You've compared -4.el6 on RHEL 6.5 to -5.el6 on RHEL-6.6, so it doesn't follow that one version is buggy and the other isn't. The only difference between -4.el6 and -5.el6 is that the latter drops the hard requirement on firstboot in the package, so that people can install only s-c-keyboard and get the text interface without having to install firstboot and its dependencies as well. This change isn't responsible for the observed behavior, the code of s-c-keyboard wasn't changed in the -5.el6 release.

I've dug deeper and found that the line triggering the missing OK button is in s-c-keyboard since version 1.2.11 and only becomes buggy in conjunction with gtk2-2.24.x (which we ship in RHEL-6.6 -- RHEL-6.5 has 2.20.1). The line is supposed to remove a horizontal separator in the dialog window which the original author considered "ugly", newer versions of gtk2 don't have it and this causes the OK button to be removed instead.

Anyway, the bug is easily solvable in s-c-keyboard, I have a patch committed to "upstream" git which just adds a check if the widget to be removed is in fact a horizontal separator.

Comment 12 Nils Philippsen 2014-09-08 13:50:12 UTC
Created attachment 935358 [details]
Proposed patch

Comment 20 errata-xmlrpc 2014-10-14 08:30:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1617.html


Note You need to log in before you can comment on or make changes to this bug.