Bug 1136840 - [engine-backend][ImportDomain] Import storage domain - tasks aren't cleared
Summary: [engine-backend][ImportDomain] Import storage domain - tasks aren't cleared
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: x86_64
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 3.5.0
Assignee: Liron Aravot
QA Contact: Elad
URL:
Whiteboard: storage
Depends On:
Blocks: 716511 rhev3.5beta3
TreeView+ depends on / blocked
 
Reported: 2014-09-03 12:11 UTC by Liron Aravot
Modified: 2016-02-10 20:20 UTC (History)
13 users (show)

Fixed In Version: org.ovirt.engine-root-3.5.0-14
Doc Type: Bug Fix
Doc Text:
Clone Of: 1130222
Environment:
Last Closed:
oVirt Team: Storage


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 32543 master MERGED core: introducing ImageSpmCommand Never
oVirt gerrit 32544 master MERGED core: AsyncTaskType - uploadImageFromStream to uploadImageToStream Never
oVirt gerrit 32545 master MERGED core: adding RetrieveImageDataCommand Never
oVirt gerrit 33276 ovirt-engine-3.5 MERGED core: introducing ImageSpmCommand Never
oVirt gerrit 33277 ovirt-engine-3.5 MERGED core: AsyncTaskType - uploadImageFromStream to uploadImageToStream Never
oVirt gerrit 33278 ovirt-engine-3.5 MERGED core: adding RetrieveImageDataCommand Never

Description Liron Aravot 2014-09-03 12:11:24 UTC
Description of problem:
When importing a storage domain the engine issues retrive image data call to download the ovf data, but the import flow never handles the tasks and it will never be cleared.

Version-Release number of selected component (if applicable):
ovirt-3.5 RC1.1
ovirt-engine-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch
vdsm-4.16.2-1.gite8cba75.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
On a new shared 3.5 DC with 2 hosts cluster without storage domains:
1. Detach storage domain with updated ovf store
2. Attach the storage domain to active dc.


Actual results:
There is unknown task in the spm, preventing to move it to maintenance

Expected results:
the task should be cleared, allowing to move the spm to maintenance

Comment 1 Elad 2014-09-03 12:28:47 UTC
Steps to Reproduce:
On a new shared 3.5 DC:
1. Detach storage domain with updated ovf store
2. Attach the storage domain to active dc.

Comment 2 Ori Gofen 2014-10-02 11:42:40 UTC
This bug should be urgent since it causing the operation of migrating SPM privileges from one host to another impossible.
which means after each import session one needs to restart oVirt engine

Comment 3 Eyal Edri 2014-10-07 07:13:09 UTC
this bug status was moved to MODIFIED before engine vt5 was built,
hence moving to on_qa, if this was mistake and the fix isn't in,
please contact rhev-integ@redhat.com

Comment 4 Elad 2014-10-07 12:47:34 UTC
uploadImageToStream tasks are being cleaned after they finish
Host can be moved to maintenance after VM registration from an imported domain


Verified using rhev3.5 vt5

Comment 5 Allon Mureinik 2015-02-16 19:13:30 UTC
RHEV-M 3.5.0 has been released, closing this bug.

Comment 6 Allon Mureinik 2015-02-16 19:13:30 UTC
RHEV-M 3.5.0 has been released, closing this bug.


Note You need to log in before you can comment on or make changes to this bug.