Bug 1136841 - improve error message when repository set enablement fails
Summary: improve error message when repository set enablement fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Transitions
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Tomas Lestach
QA Contact: Lukas Pramuk
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-03 12:11 UTC by Tomas Lestach
Modified: 2019-09-26 14:46 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:11:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC

Description Tomas Lestach 2014-09-03 12:11:29 UTC
Description of problem:
I'm running:

# hammer import all --manifest-directory ~/manif/
(pasting just the repository-enable relevant output)
...
Import repository-enable    with arguments --csv-file /tmp/exports/channels.csv
...unknown error 403, 403 Forbidden - skipping.
...unknown error 403, 403 Forbidden - skipping.
Summary
  Mapped 3 redhat_repositories.
...


Actual results:
The error message is really ugly.

Expected results:
Red Hat repository set enablement failed with '403 Forbidden'
or similar


Version-Release number of selected component (if applicable):
rubygem-hammer_cli_import-0.10.2-1.2.el6sat.noarch

How reproducible:
always

Comment 2 Grant Gainey 2015-02-11 21:03:41 UTC
PR #13 submitted

Comment 3 Tomas Lestach 2015-04-10 17:07:28 UTC
hammer-cli-import.git: 23c838c4ae5671b2ec2bce732867b8d58613a16e

Comment 4 Grant Gainey 2015-04-10 18:03:40 UTC
katello and related projects use POST when committed upstream, and reserves MODIFIED for committing downstream.

Comment 6 Lukas Pramuk 2016-03-30 12:34:17 UTC
VERIFIED.

tfm-rubygem-hammer_cli_import-0.10.23-1.el6sat.noarch
@Sat6.2.0-Beta-Snap5

to reproduce those 403 errors I didn't upload a manifest to an imported organization.

# hammer import repository-enable --verbose --csv-file /tmp/exports/channels.csv
Importing from /tmp/exports/channels.csv
Enabling /content/dist/rhel/server/5/5Server/x86_64/os/Packages for channel rhel-x86_64-server-5 in org 3
Mapping redhat repository [[1, 102]->26].
Enabling /content/dist/rhel/server/5/5Server/x86_64/os/Packages for channel rhel-x86_64-server-5 in org 4
Mapping redhat repository [[2, 102]->27].
Repository /content/dist/rhel/server/5/5Server/x86_64/os/Packages for (x86_64 x 5Server) not found!
Enabling /content/dist/rhel/server/6/6Server/x86_64/os/Packages for channel rhel-x86_64-server-6 in org 3
Mapping redhat repository [[1, 101]->28].
Enabling /content/dist/rhel/server/6/6Server/x86_64/os/Packages for channel rhel-x86_64-server-6 in org 4
Mapping redhat repository [[2, 101]->29].
Repository /content/dist/rhel/server/6/6Server/x86_64/os/Packages for (x86_64 x 6Server) not found!
Enabling /content/dist/rhel/server/7/7Server/x86_64/os/Packages for channel rhel-x86_64-server-7 in org 3
Mapping redhat repository [[1, 103]->30].
Enabling /content/dist/rhel/server/7/7Server/x86_64/os/Packages for channel rhel-x86_64-server-7 in org 4
Mapping redhat repository [[2, 103]->31].
Repository /content/dist/rhel/server/7/7Server/x86_64/os/Packages for (x86_64 x 7Server) not found!
Enabling /content/dist/rhel/server/5/5Server/x86_64/rhn-tools/os/Packages for channel rhn-tools-rhel-x86_64-server-5 in org 3
Mapping redhat repository [[1, 104]->32].
Enabling /content/dist/rhel/server/5/5Server/x86_64/rhn-tools/os/Packages for channel rhn-tools-rhel-x86_64-server-5 in org 4
Mapping redhat repository [[2, 104]->33].
Repository /content/dist/rhel/server/5/5Server/x86_64/rhn-tools/os/Packages for (x86_64 x 5Server) not found!
Enabling /content/dist/rhel/server/6/6Server/x86_64/rhn-tools/os/Packages for channel rhn-tools-rhel-x86_64-server-6 in org 3
Mapping redhat repository [[1, 105]->34].
Enabling /content/dist/rhel/server/6/6Server/x86_64/rhn-tools/os/Packages for channel rhn-tools-rhel-x86_64-server-6 in org 4
Mapping redhat repository [[2, 105]->35].
Repository /content/dist/rhel/server/6/6Server/x86_64/rhn-tools/os/Packages for (x86_64 x 6Server) not found!
Enabling /content/dist/rhel/server/7/7Server/x86_64/rhn-tools/os/Packages for channel rhn-tools-rhel-x86_64-server-7 in org 3
Mapping redhat repository [[1, 106]->36].
Enabling /content/dist/rhel/server/7/7Server/x86_64/rhn-tools/os/Packages for channel rhn-tools-rhel-x86_64-server-7 in org 4
Mapping redhat repository [[2, 106]->37].
Repository /content/dist/rhel/server/7/7Server/x86_64/rhn-tools/os/Packages for (x86_64 x 7Server) not found!
Summary
  Mapped 12 redhat_repositories.


>>> Repository /content/dist/rhel/server/7/7Server/x86_64/rhn-tools/os/Packages for (x86_64 x 7Server) not found! is more descriptive than just 403 forbiden skipping.

Comment 9 errata-xmlrpc 2016-07-27 09:11:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.