Bug 1136910 - organizations UI does not filter resources to associate based upon RBAC
Summary: organizations UI does not filter resources to associate based upon RBAC
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Users & Roles
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Tomer Brisker
QA Contact: Kedar Bidarkar
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On: 1245624
Blocks: sam20-tracker
TreeView+ depends on / blocked
 
Reported: 2014-09-03 14:50 UTC by Tom McKay
Modified: 2019-09-26 14:34 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:44:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 7337 None None None 2016-04-22 16:03:59 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Tom McKay 2014-09-03 14:50:29 UTC
The list of resources to association with an organization or location, for example subnets, does not honor the user's RBAC permissions. For example, if a user has a filter to see only subnet S1 but there are other subnets S2 and S3, all three will be displayed instead of just S1.

Also related, however, is the fact that the UI sends up the list of subnets on form submit as a group. This means that if the above case is fixed so that the user only sees S1 in the list of choices, this will lead to them effectively remove S2 and S3 if another user had added those. The UI needs to be fixed to perform separate add and remove operations on individual IDs rather than blindly posting back what it believes to be the full set.

Comment 1 Tom McKay 2014-09-03 14:50:30 UTC
Created from redmine issue http://projects.theforeman.org/issues/7337

Comment 4 Bryan Kearney 2015-05-21 10:03:23 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/7337 has been closed
-------------
Anonymous
Applied in changeset commit:887e2fd905a470cfd8d2f7db25d1b4274c548afc.

Comment 5 Marek Hulan 2015-07-22 12:23:29 UTC
Should be merged together with https://bugzilla.redhat.com/show_bug.cgi?id=1245624

Comment 6 Tazim Kolhar 2015-11-10 06:42:48 UTC
hi 

please provide verification steps

thanks and regards,
Tazim

Comment 7 Tom McKay 2016-01-12 18:44:43 UTC
For example, if a user has a filter to see only subnet S1 but there are other subnets S2 and S3, all three will be displayed instead of just S1.

^^ That is the reproducer.

Comment 11 Kedar Bidarkar 2016-05-03 16:37:47 UTC
VERIFIED With sat62-snap9.3

1) Created a subnet subnet_111 (vlanid 211) and subnet_112 ( no vlan id )
2) Created a role called "foreman_role" for subnet "view subnet" and limited the scope for it using "vlanid 211", so that only subnet_111 is visible.
3) Created a user "kbidarka" and assigned the role "foreman_role"
4) Upon logging in as user kbidarka, we can now see only the "subnet_111" and not subnet_112

--------

5) Assigned subnet_112, the vlanid 211 and we can now see both the subnet's when logging in as kbidarka user.

Comment 13 errata-xmlrpc 2016-07-27 08:44:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.