Bug 113712 - unable to rpm -qa after run /usr/lib/rpm/rpmdb_verify Packages OK
Summary: unable to rpm -qa after run /usr/lib/rpm/rpmdb_verify Packages OK
Status: CLOSED DUPLICATE of bug 113710
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpmdb-redhat (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-16 18:47 UTC by helen wang
Modified: 2007-04-18 17:01 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:00:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description helen wang 2004-01-16 18:47:38 UTC
I am having rpm problem in RH9 after running up2date, either user or 
root can not query rpm packages
error message: 
#rpm -qa
rpmdb: /var/lib/rpm/Packages: unsupported hash version: 8
error: cannot open Packages index using db3 - Invalid argument (22)
error: cannot open Packages database in /var/lib/rpm
no packages

after follow the instructions descripted in 
http://www.rpm.org/hintskinks/repairdb/

I have done as root:
#cd /var/lib/rpm
rm -f /var/lib/rpm/__db*
rpm -vv --rebuilddb

I got message:
# rpm -vv --rebuilddb
D: rebuilding database /var/lib/rpm into /var/lib/rpmrebuilddb.15334
D: creating directory /var/lib/rpmrebuilddb.15334
D: opening old database with dbapi 3
D: opening  db environment /var/lib/rpm/Packages create:cdb:mpool
D: opening  db index       /var/lib/rpm/Packages rdonly mode=0x0
rpmdb: /var/lib/rpm/Packages: unsupported hash version: 8
D: closed   db index       /var/lib/rpm/Packages
D: closed   db environment /var/lib/rpm/Packages
error: cannot open Packages index
D: removing directory /var/lib/rpmrebuilddb.15334

so I did
#cd /var/lib/rpm
# rm -f __db.00*
# /usr/lib/rpm/rpmdb_verify Packages

no error message at this time
then I did 
#rpm -qa
I got:
rpmdb: /var/lib/rpm/Packages: unsupported hash version: 8
error: cannot open Packages index using db3 - Invalid argument (22)
error: cannot open Packages database in /var/lib/rpm
no packages


what shall I do to fix it now? 

Thanks a lot!!

Helen

Comment 1 Jeff Johnson 2004-01-16 19:21:33 UTC

*** This bug has been marked as a duplicate of 113710 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:00:48 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.