Bug 113744 - perl cannot find XML::Parser
perl cannot find XML::Parser
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: perl-XML-Parser (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Warren Togami
:
: 113736 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-16 18:44 EST by Jonathan Blandford
Modified: 2013-04-02 00:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-17 19:58:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Blandford 2004-01-16 18:44:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031003

Description of problem:
The perl module path does not seem to contain
/usr/lib64/perl5/vendor_perl/5.8.0/, and instead only looks in
/usr/lib/perl5/vendor_perl/5.8.2/.  As a result, XML::Parser can't be
found.  This means that no package (including most of GNOME) using the
new intltool will build.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
[root@thor /]$ perl -e "require XML::Parser"
Can't locate XML/Parser.pm in @INC (@INC contains:
/usr/lib64/perl5/5.8.2/x86_64-linux-thread-multi /usr/lib/perl5/5.8.2
/usr/lib64/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.2
/usr/lib/perl5/site_perl/5.8.1/x86_64-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.1
/usr/lib/perl5/site_perl/5.8.0/x86_64-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl
/usr/lib64/perl5/vendor_perl/5.8.2/x86_64-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.2
/usr/lib/perl5/vendor_perl/5.8.1/x86_64-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.1
/usr/lib/perl5/vendor_perl/5.8.0/x86_64-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl
/usr/lib/perl5/5.8.1/5.8.2/x86_64-linux-thread-multi
/usr/lib/perl5/5.8.1/5.8.2
/usr/lib/perl5/5.8.1/x86_64-linux-thread-multi /usr/lib/perl5/5.8.1
/usr/lib/perl5/5.8.0/5.8.2/x86_64-linux-thread-multi
/usr/lib/perl5/5.8.0/5.8.2
/usr/lib/perl5/5.8.0/x86_64-linux-thread-multi /usr/lib/perl5/5.8.0 .)
at -e line 1.
[root@thor /]$ rpm -ql perl-XML-Parser |grep Parser.pm
/usr/lib64/perl5/vendor_perl/5.8.0/x86_64-linux-thread-multi/XML/Parser.pm


Additional info:

I'm guessing that rebuilding it with the newer perl will fix this.
Comment 1 Chip Turner 2004-01-19 17:49:50 EST
this should now be building
Comment 2 Justin M. Forbes 2004-01-26 17:08:46 EST
*** Bug 113736 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.