Bug 11377 - adding ATALK support to rhs-printfilters
adding ATALK support to rhs-printfilters
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rhs-printfilters (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-12 00:53 EDT by Roland Roberts
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-12 00:53:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Roland Roberts 2000-05-12 00:53:01 EDT
Back in 5.x, I made a small change to the filter script to allow printing
to an AppleTalk printer hanging off my wife's Mac.  This requires you
install the appletalk bridge system extension on the mac (available from
Apple's FTP site).

Here's the unified diff against 6.1's master-filter.  You will also note
the reference to the .paprc file in the lpd directory.  That file merely
contains the name of the printer; in my case it is "OL610e/PS:LaserWriter"
but anyone using this can get if from nbplkup.


682 root> diff -u /usr/lib/rhs/rhs-printfilters/master-filter filter
--- /usr/lib/rhs/rhs-printfilters/master-filter Tue Sep 14 17:40:26 1999
+++ filter      Mon Jan  5 22:35:15 1998
@@ -355,9 +355,10 @@
 #   any post-filter to run (like smbclient?)
 #
     if [ "$PRINTER_TYPE" = "SMB" ]; then
-       bestpath="$bestpath | ${FPIDIR}/smbprint ${SPOOLDIR}/acct"
-    elif [ "$PRINTER_TYPE" = "NCP" ]; then
-       bestpath="$bestpath | ${FPIDIR}/ncpprint ${SPOOLDIR}/acct"
+      bestpath="$bestpath | ${FPIDIR}/smbprint ${SPOOLDIR}/acct"
+    elif [ "$PRINTER_TYPE" = "ATALK" ]; then
+      PNAME="`cat ${SPOOLDIR}/.paprc`"
+      bestpath="$bestpath | /usr/bin/pap -p $PNAME"
     fi

     if [ "$DEBUG_FILTER" != "" ]; then
@@ -367,7 +368,7 @@
 #
 # run the command!
 #
-    eval $bestpath 2>/dev/null
+    eval $bestpath

 #
 #
Comment 1 Bernhard Rosenkraenzer 2000-06-23 07:47:19 EDT
Thanks, I've added something similar to the current CVS. Your patch in its
original form is broken because it breaks NCP printing.

Note You need to log in before you can comment on or make changes to this bug.