Bug 113791 - HPT366 read errors from drive when used with WDC 40Gb UDMA4 drive
HPT366 read errors from drive when used with WDC 40Gb UDMA4 drive
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-17 21:44 EST by Need Real Name
Modified: 2007-04-18 13:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-17 22:09:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-01-17 21:44:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
I have a TYAN BE6 revision 1 motherboard.  This motherboard has a 
HPT366 controller built-in in addition to 2 standard IDE 
controllers.  I have installed a Western Digital WD400BB drive on the 
1st HPT366 controller.  This drive support up to ATA100.  Since the 
drive is on a ATA66 controller I set the max speed of the drive using 
WDC utilities to ATA66.  For some reason the kernel detects that the 
max speed of the drive is UDMA4(ATA100).  This causes large reads to 
become corrupted.  I noticed issues when trying to use this machine 
as a kickstart server.  The remote machine would get MD5 errors on 
various packages during NFS transfers.  I ended up using hdparm -X 
udma2 /dev/hdg1 to resolve the issue temporarily.  I was also seeing 
issues when writing large amounts of data to this drive.

Version-Release number of selected component (if applicable):
kernel-2.4.20-8

How reproducible:
Always

Steps to Reproduce:
1. TYAN BE6 board with HPT366 controller
2. Western Digital UDMA4 Drive
3. Connect drive to 1 of the HPT366 controllers.
4. Set drive with WDC utilities to UDMA2
5. Create a filesystem on this drive.
6. Use this filesystem as your kickstart software repository
7. Share the filesystem using NFS
8. Attempt a kickstart install from a remote client.
    

Actual Results:  MD5 errors occured a different places during the 
kickstart install and it would fail.  Multiple attempts would cause 
different packages to appear corrupted.

Expected Results:  Good kickstart install

Additional info:
Comment 1 Need Real Name 2004-01-17 22:09:26 EST
My original text has a bunch or errors.  I will go back and recollect 
my data and re-open if this ends up not being hardware.

Note You need to log in before you can comment on or make changes to this bug.