Bug 113805 - bell does not work in X
bell does not work in X
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-18 11:15 EST by Jonathan Rawle
Modified: 2015-01-04 17:04 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-19 02:30:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Rawle 2004-01-18 11:15:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux)

Description of problem:
The system bell does not function from within the X window environment. Typing the xkbbell command should cause the bell to sound, but this is not the case. There is also no bell in programs such as xterm. Changing the bell parameters using the xset utility has no effect.

The system bell works find when using a virtual terminal, so this is not a hardware problem.

Version-Release number of selected component (if applicable):
XFree86-4.3.0-42

How reproducible:
Always

Steps to Reproduce:
1. Log in to an X windows session
2. Open a terminal window
3. xkbbell
    

Actual Results:  Nothing

Expected Results:  The system bell sounds

Additional info:
Comment 1 Mike A. Harris 2004-01-18 12:12:19 EST
<mharris> Ok, fellow fedora developers/testers...  here's a quickie
for you to test
<mharris> https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=113805
<mharris> Please test running "xkbbell" as per the above bug report,
and indicate wether you can reproduce this user's problem or not.  (I
can't)
<jacob> mharris, I can reproduce it
<Reivec> mharris, ditto, no bell here
<jacob> mharris, but I noticed that the normal bell when you X fires
up for the first time isnt sounding anymore after I switched to kernel
2.6.1 rpm
<mharris> works for me  ;o/
<mharris> oh
<mharris> I'll try on 2.6
<Reivec> mharris, yeah, I am on 2.6
<rsc_> btw, there are problems with touchpads and the touchpad-buttons
at laptops in 2.6 ;)

[...]

<mharris> Ok, I've reproduced both inside X, and outside X in 2.6.
<mharris> Looks like a kernel bug.
<mharris> Can you guys who also reproduced this, also try switching to
a VC and doing:  echo -e '\007'
<mharris> the echo, should produce a single beep
<mharris> I get a beep in 2.4 kernel both in X and out of X.  (X
version doesn't matter, tried 4.1.0 and 4.3.0, both work)
<mharris> with 2.6 I get no beep at all in or out of X.

[...]

<Reivec> mharris, no beep with echo
<jacob> mharris, no beep in VC using 2.6


Ok, this looks like a kernel bug now.  I suggest that you also
try switching to a virtual console and try using the following
command to try and produce a beep:  echo -e '\007'

If you do not get a beep sound, please reboot into the Fedora
Core 1 2.4.x kernel (this bug is filed against Fedora Core 1)
and try to reproduce both in X, and outside X as above.  That
should confirm wether or not this is a problem that manifests
only under 2.6.x, however it currently appears to be a kernel
issue to me.

Reassigning to the kernel component, as I get no beep under 2.6.x
even without XFree86 running on the system at all.
Comment 2 Jonathan Rawle 2004-01-18 12:24:10 EST
I am indeed using Fedora Core 1 with the current stable Kernel 
2.4.22-1.2149.nptlsmp. I did notice it with earlier Kernels too. I 
tried echo -e '\007' - it beeps in a VC but not from within X. 
Comment 3 Mike A. Harris 2004-01-19 16:15:02 EST
I'm unable to reproduce this with a 2.4.x kernel.
Comment 4 Jonathan Rawle 2004-01-19 16:26:14 EST
I really don't think this is a Kernel bug. I've tried it with a 
2.6.0 kernel that I compiled from source, and I get exactly the same 
- bell in VC but not in X. 
 
Comment 5 Mike A. Harris 2004-01-19 17:16:50 EST
As mentioned above, I am not able to reproduce the specific problem
that you describe in this bug report, under Fedora Core 1, using
the official Fedora Core kernel, at all period.  I would have
closed the bug report as WORKSFORME, however I tried to get other
people to test this out and provide me their feedback as well in
IRC.  The results of my IRC conversation are above, slightly edited
to remove parts of the discussion that were unnecessary to the
topic at hand.

So as this stands right now, I did reproduce the problem you are
describing while booted into the Fedora development kernel, which
is 2.6.x based, as did many other people.  All of the people who
could reproduce the problem you describe, did so under the 2.6.x
kernel, and simultaneously were not able to get the console to
beep on a virtual console login (not inside X).  As such, it would
appear that the kernel (2.6.x) has problems in this area.

For 2.4.x kernels, both myself and everyone else who tried to
reproduce this, was unable to reproduce it on 2.4.x official kernel
updates we've shipped.  It is possible that whatever the problem
is, that it is also present in the 2.4.x kernel as well, but that
it only triggers for some people and not for others for some reason.

So, I do consider this to be a kernel bug, even if you are not
able to observe the same behaviour as what I describe above.
Comment 6 Jonathan Rawle 2004-01-22 05:33:15 EST
I was able to try this on another machine running Fedora, and I 
couldn't reproduce it either. This makes me think it's some other 
aspect of my configuration, although I did look into that before 
submitting the original report. Whether my problem is due to the 
Kernel or not, there does seem to be a bug in 2.6.0 which should be 
fixed anyway I suppose. 
Comment 7 Christopher Johnson 2004-02-14 13:11:03 EST
Reproduced lack of beep in VC and terminal within X.  Also no GDM
beep. All other sound functions correctly.  My config is
kernel-2.6.1-1.65, alsa-lib-1.0.2-1, alsa-utils-1.0.2-1, using
snd-ali5451 module on a Compaq Presario 2100. 
Comment 8 Jonathan Rawle 2004-02-18 06:54:12 EST
Since upgrading to KDE 3.2, the bell now sounds in X! So as far as 
my original report is concerned, I consider the matter to be closed. 
Comment 9 Mike A. Harris 2004-02-19 02:30:45 EST
Ok, I'm closing this report now then as your issue seems to be
resolved.

It is possible however that whatever the problem was, may still
exist, because some people were having it occur in the console
without X even running.  I was able to reproduce that.

It does not appear that this problem is being reported by a large
number of users however, and kernel developers I've talked to about
it have not commented about it, so I'm assuming that it isn't a
large or common issue.
Comment 10 Aaron VanDevender 2004-04-18 16:00:11 EDT
I'm still seeing this with FC2-test2. It does not sound a bell in
either X or a VC.

Comment 11 Dave Jones 2004-04-19 07:21:13 EDT
modprobe pcspkr ?
Comment 12 Aaron VanDevender 2004-04-19 20:58:31 EDT
modprobe pcspkr got the bell working. But why would I have to load
this by hand. Should there by a modprobe.conf line that takes care of it?
Comment 13 Michael Gilchrist 2004-09-01 20:09:15 EDT
So does anyone have a final fix for this?  I'm running FC 2 with
kernel 2.6.8 and don't get a bell unless I execute the modprobe pcspkr
command.  Should I change my modprobe.conf file and if so how?  Is
there another fix?

Note You need to log in before you can comment on or make changes to this bug.