Bug 1138131 - [RFE][ImportDomain] The login button, when picking the targets for importing iSCSI Storage domain should be more noticeable in the GUI
Summary: [RFE][ImportDomain] The login button, when picking the targets for importing ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Amit Aviram
QA Contact: Kevin Alon Goldblatt
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-04 06:46 UTC by Maor
Modified: 2016-03-09 20:39 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-09 20:39:51 UTC
oVirt Team: Storage
sherold: Triaged+


Attachments (Terms of Use)
solution mockup (216.11 KB, application/octet-stream)
2014-09-15 12:17 UTC, Eldan Hildesheim
no flags Details
screenshot (186.86 KB, image/png)
2015-07-08 15:17 UTC, Kevin Alon Goldblatt
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 41051 master MERGED UI: Fix header buttons in import iScsi target Never

Description Maor 2014-09-04 06:46:52 UTC
Description of problem:
The login button, when picking the targets for importing iSCSI Storage domain is currently at the top of the dialog, and when picking the targets and scroll down, the user might be confused how to login

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Try to add iSCSI domain, and pick the targets
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Allon Mureinik 2014-09-04 10:53:29 UTC
Maor, please attach a screenshot explaining the problem so the UX experts can suggest an improvement.

Comment 3 Einav Cohen 2014-09-10 18:13:32 UTC
indeed, the "Login" button can be easily missed; I am wondering why the login GUI in the Import Domain dialog  (select rows, hit "login" on top-left) is so different than the login GUI within the New Domain dialog (an inline "login" button, in addition to a "login all" button on top-right)? because I think that just copying the login GUI from the "New Domain" dialog would fit here. 

Allon/Maor/Eldan: thoughts?

Comment 4 Allon Mureinik 2014-09-11 13:23:50 UTC
(In reply to Einav Cohen from comment #3)
> indeed, the "Login" button can be easily missed; I am wondering why the
> login GUI in the Import Domain dialog  (select rows, hit "login" on
> top-left) is so different than the login GUI within the New Domain dialog
> (an inline "login" button, in addition to a "login all" button on
> top-right)? because I think that just copying the login GUI from the "New
> Domain" dialog would fit here. 
> 
> Allon/Maor/Eldan: thoughts?

+1 on that.
Maor - is it an intentionally different button?

Comment 5 Eldan Hildesheim 2014-09-15 12:17:52 UTC
Created attachment 937580 [details]
solution mockup

Take the Discover Target and Login button outside the scroll.
When scrolling threw the targets the button will be static and visible all the way.

Comment 6 Maor 2014-09-30 09:43:52 UTC
(In reply to Allon Mureinik from comment #4)
> (In reply to Einav Cohen from comment #3)
> > indeed, the "Login" button can be easily missed; I am wondering why the
> > login GUI in the Import Domain dialog  (select rows, hit "login" on
> > top-left) is so different than the login GUI within the New Domain dialog
> > (an inline "login" button, in addition to a "login all" button on
> > top-right)? because I think that just copying the login GUI from the "New
> > Domain" dialog would fit here. 
> > 
> > Allon/Maor/Eldan: thoughts?
> 
> +1 on that.
> Maor - is it an intentionally different button?

One button is for login to the targets (which should be picked first)
The other button is for importing the Storage Domains discovered from the targets.
I think it is better they should be separated and different since they reflect different scenarios.
The mockup which Eldan attached seems to do the trick

Comment 7 Max Kovgan 2015-06-28 14:12:58 UTC
ovirt-3.6.0-3 release

Comment 8 Kevin Alon Goldblatt 2015-07-08 15:15:21 UTC
Verified using Version:
--------------------------------------
vdsm-4.17.0-1054.git562e711.el7.noarchrpm -qa 
ovirt-engine-3.6.0-0.0.master.20150627185750.git6f063c1.el6.noarch


Verified with the following scenario:
--------------------------------------
Steps to reproduce:
1. Via Storage Tab -> Import Domain -> Discover Targets -> Select an IQN in the list -> The login button is activated and is Clear

Moving to VERIFIED!

Added Screen shot of solution!

Comment 9 Kevin Alon Goldblatt 2015-07-08 15:17:30 UTC
Created attachment 1049909 [details]
screenshot

Added screen shot of solution

Comment 11 errata-xmlrpc 2016-03-09 20:39:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.