Bug 1138139 - [RFE][ImportDomain] Adding a button to import floating and unregistered disks
Summary: [RFE][ImportDomain] Adding a button to import floating and unregistered disks
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-4.0.0-alpha
: 4.0.0
Assignee: Maor
QA Contact: Kevin Alon Goldblatt
URL:
Whiteboard:
: 1210498 (view as bug list)
Depends On: 1317437
Blocks: 902971 Gluster-HC-2 1324866
TreeView+ depends on / blocked
 
Reported: 2014-09-04 07:11 UTC by Maor
Modified: 2016-08-23 20:21 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
This release adds the ability to register unregistered floating disks through the GUI. Previously, because floating disks are not part of any virtual machine or template, the user could only register floating disks from the REST API, not from the GUI. Now there is a subtab in the GUI called "Import Disk" which allows the user to register a floating disk into the setup. Storage domains also support a functionality called "Scan Disks", which scans the storage domain for unregistered floating disks that are not reflected in the setup. This can be helpful for managing disks from external storage domains.
Clone Of:
: 1317437 (view as bug list)
Environment:
Last Closed: 2016-08-23 20:21:06 UTC
oVirt Team: Storage
sherold: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1743 normal SHIPPED_LIVE Red Hat Virtualization Manager 4.0 GA Enhancement (ovirt-engine) 2016-09-02 21:54:01 UTC
oVirt gerrit 54182 master MERGED dal: Introduce unregistered disks table. 2016-03-21 07:55:38 UTC
oVirt gerrit 54260 master MERGED core: Fix typo 2016-03-21 07:55:32 UTC
oVirt gerrit 54390 master MERGED core: Update unregistered disks in DB on attach. 2016-03-21 07:55:54 UTC
oVirt gerrit 54479 master MERGED core: Remove unregistered disks once an entity gets registered. 2016-03-21 07:56:07 UTC
oVirt gerrit 54480 master MERGED core: Remove unregistered disk once it gets registered. 2016-03-21 07:56:19 UTC
oVirt gerrit 54481 master MERGED core: Introduce GetUnregisteredDisksFromDBQuery 2016-03-21 07:56:29 UTC
oVirt gerrit 54489 master MERGED core: Add a command for scanning unregistered disks. 2016-03-21 07:55:43 UTC
oVirt gerrit 54831 master MERGED webadmin: Add import disks sub tab 2016-03-27 09:46:04 UTC
oVirt gerrit 54832 master MERGED dal: Update unregistered view with disks 2016-03-27 09:48:13 UTC
oVirt gerrit 55002 master MERGED core: Fix findbugs 2016-03-21 14:53:22 UTC
oVirt gerrit 55058 master MERGED core: improvements at ScanStorageForUnregisteredDisks. 2016-03-27 09:50:45 UTC
oVirt gerrit 55059 master MERGED webadmin: Add support for scan unregistered disks 2016-03-27 09:58:58 UTC
oVirt gerrit 55060 master MERGED core: Set storage domain id when scan for unregister disk. 2016-03-27 09:59:13 UTC
oVirt gerrit 55202 master MERGED core: Add image id for unregistered disk BE. 2016-03-27 10:00:50 UTC
oVirt gerrit 55203 master MERGED core: Add lock for register disk command. 2016-03-27 10:03:38 UTC
oVirt gerrit 55204 master MERGED core: Adding lock for scan storage domain. 2016-03-27 10:04:28 UTC
oVirt gerrit 55331 master MERGED dal: Update creation date in unregistered map table. 2016-03-30 07:05:59 UTC
oVirt gerrit 55332 master MERGED webadmin: Dont show unregistered subtab if SD is unattached. 2016-03-30 08:41:23 UTC
oVirt gerrit 55333 master MERGED webadmin: Column fixes in unregistered disks sub tab. 2016-03-30 08:41:18 UTC
oVirt gerrit 55334 master MERGED core: Adding a flag to register disk parameters 2016-03-30 08:41:14 UTC
oVirt gerrit 55335 master MERGED core: Use the refresh indicator for fetching unreg disk. 2016-03-30 08:41:08 UTC
oVirt gerrit 55336 master MERGED webadmin: remove use of redundant query in list model. 2016-03-30 08:41:02 UTC
oVirt gerrit 55347 master MERGED dal: Fix fetch of unregistered disks to update attached vms. 2016-03-30 08:40:56 UTC
Red Hat Knowledge Base (Solution) 1411133 None None None Never

Description Maor 2014-09-04 07:11:45 UTC
Description of problem:
There should be an extra button in the GUI which will import all those floating disks. Currently those disks will not have an alias, this should be fixed once the alias will be saved in the description meta data.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Try to import a Storage Domain with floating disks
2.
3.

Actual results:
Those floating disks could only be registered through the REST

Expected results:
There should be a button to register all the floating disks

Additional info:

Comment 1 Allon Mureinik 2015-04-12 14:29:19 UTC
*** Bug 1210498 has been marked as a duplicate of this bug. ***

Comment 4 Yaniv Lavi 2015-04-14 20:47:26 UTC
(In reply to Allon Mureinik from comment #3)
> I'm not going to split hairs about whether this is a bug or an RFE.
> 
> From an engineering standpoint, this is a reasonable amount of work, and
> frankly, worth considering for zstream based on capacity and prioritization
> vs. other bugs.
> 
> Yaniv/Aharon - your feedback would be appreciated.

Marina, please consider the main reason to add the import domain feature was DR, not moving storage from one DC to another.

We can explore that once it's in and we know the change size and risk. Is that any workaround for the customer to readd the vdisks?

Comment 5 Allon Mureinik 2015-04-14 20:52:39 UTC
(In reply to Yaniv Dary from comment #4)
> Is that any workaround for the customer to readd the vdisks?
The backend and REST API parts are already there.
This BZ is about exposing the same functionality in the webadmin.

Comment 14 Mike McCune 2016-03-28 23:07:19 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 15 Allon Mureinik 2016-04-07 08:41:54 UTC
Maor, as far as I understand, the GUI part is merged, and we're just lacking some REST parts.

If this is correct, can you please move this BZ to MODIFIED and open a new one on the REST parts?

Comment 16 Maor 2016-04-07 13:22:04 UTC
opened https://bugzilla.redhat.com/1324866 - [RFE] Add rest API for getting unregistered disks from DB table and scan storage domain for unregistered disks

move bug to modify

Comment 18 Kevin Alon Goldblatt 2016-06-07 13:19:15 UTC
Test the with the following code:
------------------------------------------
rhevm-4.0.0.2-0.1.el7ev.noarch
vdsm-4.18.1-11.gita92976e.el7ev.x86_64


Tested with the following scenario:
-------------------------------------
1.Created 3 types of Storage Domains, scsci, nfs and fc
2.Created 3 floating disks on each
3.First put into maintenance, then detached, and then removed all 3 domains without Formatting them
4.Via the Storage Tab imported the domains again successfully
5.Via the Storage Tab selected each domain and attached and activated them again
6.Via the Storage Tab selected the newly imported, attached and activated storage domains - selected the 'Disk Import' tab - all the floating disks are displayed. Select all the floating disks and successfully imported them.

Now to perform a Full Test Cycle as this is an RFE.

Comment 19 Kevin Alon Goldblatt 2016-07-12 16:49:25 UTC
Verified with the followiing code:
------------------------------------
vdsm-4.18.4-2.el7ev
engine-root-4.0.0.6-1


MOVING TO VERIFIED!

Comment 23 errata-xmlrpc 2016-08-23 20:21:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1743.html


Note You need to log in before you can comment on or make changes to this bug.