Bug 113814 - find segfaulted
find segfaulted
Status: CLOSED DUPLICATE of bug 113555
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-18 15:02 EST by Kaj J. Niemi
Modified: 2007-04-18 13:01 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaj J. Niemi 2004-01-18 15:02:11 EST
Description of problem:
Did find /proc -name '*ecn*' which resulted in find segfaulting and
then getting a kernel traceback. This was a IBM T40p laptop and ACPI
is turned on.

Version-Release number of selected component (if applicable):
2.6.1-1.47

How reproducible:
Seems to be rather reliably reproduceable.

Steps to Reproduce:
1. find /proc -name '*ecn*'
2.
3.
  
Actual results:
proc_iget: using deleted entry e, count=1
de_put: deferred delete of e
Unable to handle kernel paging request at virtual address 6b6b6b6d
 printing eip:
c01bbb00
*pde = 00000000
Oops: 0000 [#1]
CPU:    0
EIP:    0060:[<c01bbb00>]    Not tainted
EFLAGS: 00010202
EIP is at proc_lookup+0x40/0xc0
eax: ec8ad7f4   ebx: 6b6b6b6b   ecx: e3217f78   edx: 00006b6b
esi: fffffff4   edi: ec8ad874   ebp: 00000002   esp: e3217e98
ds: 007b   es: 007b   ss: 0068
Process find (pid: 4406, threadinfo=e3216000 task=e68b8920)
Stack: fffffffe 00000000 e25d3190 ec8ad7f4 c0367d20 fffffff4 ec8ad874
ec8ad7f4
       c0188083 e25d3190 e3217f78 e3217f20 00000000 e3217f78 e3217f18
e3217f20
       c018847e f7fb780c e3217f20 f27c9002 00000000 ec8ad7f4 c0188b01
00000000
Call Trace:
 [<c0188083>] real_lookup+0xd3/0x100
 [<c018847e>] do_lookup+0x7e/0x90
 [<c0188b01>] link_path_walk+0x671/0xcc0
 [<c0183388>] cp_new_stat64+0x118/0x130
 [<c0189af8>] open_namei+0x88/0x410
 [<c01743dd>] filp_open+0x2d/0x60
 [<c0174b2d>] sys_open+0x4d/0x80
 [<c010c4cf>] syscall_call+0x7/0xb
 
Code: 0f b7 53 02 39 ea 74 3d 8b 5b 28 85 db 75 f1 8b 4c 24 04 85
  


Expected results:
Definetly not a segfault ;-)

Additional info:
Would this be the problem fixed by arjan in his kernel released Jan 17th?
Comment 1 Arjan van de Ven 2004-01-19 04:45:43 EST

*** This bug has been marked as a duplicate of 113555 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:00:49 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.