This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 113816 - slocate doesn't exclude /sys or sysfs
slocate doesn't exclude /sys or sysfs
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: slocate (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
: Patch
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-01-18 15:22 EST by Kaj J. Niemi
Modified: 2014-03-16 22:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-16 05:12:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kaj J. Niemi 2004-01-18 15:22:38 EST
Description of problem:
It would be nice if slocate would exclude sysfs, usbdevfs filesystems
by default. I guess adding them to /etc/cron.daily/slocate.cron is
enough since /etc/updatedb.conf doesn't seem to be in use.

New directories to exclude would be /sys and /udev I think.

Version-Release number of selected component (if applicable):
2.6.0-10

Thanks :)
Comment 1 Miloslav Trmac 2004-01-19 13:42:52 EST
Triage->Easyfix
Comment 2 Kaj J. Niemi 2004-02-18 12:42:47 EST
Trivial diff to slocate.cron below:

--- slocate.cron.old    2004-02-18 19:45:51.121171896 +0200
+++ slocate.cron        2004-02-18 19:46:35.282831132 +0200
@@ -1,3 +1,3 @@
 #!/bin/sh
 renice +19 -p $$ >/dev/null 2>&1
-/usr/bin/updatedb -f "nfs,smbfs,ncpfs,proc,devpts" -e
"/tmp,/var/tmp,/usr/tmp,/afs,/net"
+/usr/bin/updatedb -f "nfs,smbfs,ncpfs,proc,devpts,sysfs,usbdevfs" -e
"/tmp,/var/tmp,/usr/tmp,/afs,/net,/udev"

Comment 3 Kaj J. Niemi 2004-03-26 15:44:31 EST
I guess this one could be considered as nice to have for FC2 and
linked to bug #114963? Thanks.
Comment 4 Karsten Hopp 2004-04-16 05:12:01 EDT
fixed in slocate-2.7-9 

Note You need to log in before you can comment on or make changes to this bug.