Bug 11382 - Ghost image of rubber band left in gnome desktop
Ghost image of rubber band left in gnome desktop
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-12 05:34 EDT by percy
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-13 16:05:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description percy 2000-05-12 05:34:34 EDT
When I draw a rubber band on the gnome desktop by drag the mouse on the
left mouse button, I got ghost image of the rubber band left on the destop.
The ghost image can fill up the rectangular area formed by the rubber band
when I drag it slowly. It will disappear when foreground app covers it and
forces the background to be redrawn.

I am using Leadtek s320 which is a TNT based board running XFree 3.3.6 at
32bpp. It seems to me that it is TNT/32bpp and Gnome specific. I cannot
reproduce it in KDE 16bpp, KDE 32bpp, Gnome 16bpp. Creative TNT/TNT2 also
has similar problem. Other video cards do not exhibit this (at least on my
notebook with Trident Cyber 9325 running at 24bpp/RH6.1). I have tried
XFree 3.3.5 for RH6.1 also got this problem but it doesn't seem to happen
on XFree3.3.3.1/RH6.0.
Comment 1 Preston Brown 2000-05-24 15:38:59 EDT
looks like a chipset problem, but not sure why other XOR operations don't
produce the same symptom.
Comment 2 David Mason 2000-05-24 16:10:59 EDT
jonathan - is this a GMC problem?
Comment 3 Jonathan Blandford 2001-01-10 11:14:28 EST
It's more likely to be an X (or hardware) problem then a chipset problem.  The
only time I've ever seen gmc not do that correctly is when it's been a hardware
issue.
Comment 4 Mike A. Harris 2001-07-13 15:59:45 EDT
I believe Preston meant a graphics chipset related issue, not a
motherboard chipset issue..  I have seen a single time before that something
like this occured in GNOME.  It was totally unrepeatable and I never saw it
since.  I don't recall what video hardware I was using, but I am about 95%
sure it was a Cirrus Logic 5446.  Not sure which release of RHL/X it was either,
but I believe it was 4.0.1 in 7.0.

You say you're using a TNT card, and I know that they are not well supported
in X, so this very well could be a driver problem.  Can you please attach
your X server log and your config file to the bug report using the link
below?  Also, if you have not upgraded to our released errata of XFree86 for
Red Hat Linux 6.2, could you please do so, and update the report with wether
or not it fixes the problem?

The support for Nvidia hardware is, from what I understand, much better in
the just released XFree86 4.1.0, however I do not have any NVidia hardware
myself with which to test.
Comment 5 Mike A. Harris 2001-08-08 11:15:18 EDT
Closing bug report due to lack of response on issue, assuming
fixed or user can't supply info anymore, or has changed video
hardware.

Note You need to log in before you can comment on or make changes to this bug.