Bug 113828 - RPM incorrectly Obsoletes official project RPMs
RPM incorrectly Obsoletes official project RPMs
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: spamassassin (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-18 22:01 EST by Theo Van Dinter
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-01 00:49:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Theo Van Dinter 2004-01-18 22:01:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-us) AppleWebKit/106.2 (KHTML, like Gecko) Safari/100.1

Description of problem:
I'm the maintainer of the official SpamAssassin RPMs.  At the moment, the latest version is spamassassin-2.62-1 and perl-Mail-SpamAssassin-2.62-1.  Unfortunately, on my ES3 server, which has the above RPMs installed, "up2date -l" reports that the RedHat spamassassin RPM (spamassassin-2.55-3.1) needs to be installed and it obsoletes perl-Mail-SpamAssassin.

After looking at the RedHat spec file, and discussing the issue on rpm-list@redhat.com, the only suggestion was that I file this bug for the RPM.  From the discussion, it looks like the Obsoletes line ought to limit itself to certain versions of perl-Mail-SpamAssassin.  Right now, it looks like:

Obsoletes: perl-Mail-SpamAssassin

but should be something like:

Obsoletes: perl-Mail-SpamAssassin < %{version}

so that people who install the newer "official" RPMs won't have problems with the RH older version obsoleting incorrectly.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install the official project spamassassin and perl-Mail-SpamAssassin RPMs
2. run "up2date -l"


Additional info:
Comment 2 Mark Leary 2004-04-13 11:45:45 EDT
Another problem with the RedHat release of spamassassin...  Version 
2.55 has a bug wich gives a high score to all messages sent using 
Outlook 2003.  The failed tests are "Forged mail pretending to be 
from MS Outlook" (3.5) and " Message looks like Outlook, but isn't" 
(0.6).  This is fixed in newer versions.

Note You need to log in before you can comment on or make changes to this bug.