Bug 113831 - SDL Crashes with gl-117 or scorched3d
SDL Crashes with gl-117 or scorched3d
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: SDL (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-19 02:08 EST by Eli Wapniarski
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-14 07:04:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eli Wapniarski 2004-01-19 02:08:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux) (KHTML, like Gecko)

Description of problem:
Compiled or installed a couple of games, gl-117 and scorched3d both games segfaulted with and SDL parachute message. I went to SDL sites and replaced the Fedora rpms with RPMs supplied by SDL and both games seemed to work fine.

Version-Release number of selected component (if applicable):
SDL-1.2.5-9, SDL_image-1.2.3-3, SDL_mixer-1.2.4-9, SDL_net-1.2.4-8

How reproducible:
Always

Steps to Reproduce:
1. Install g-117 or scorched3d
2. Run either game
3. 
    

Actual Results:  Segfault with SDL parachute message

Expected Results:  Games should run

Additional info:
Comment 1 Christopher Stone 2004-02-02 00:07:30 EST
I get this error with tons of SDL apps, dosbox, frozen-bubble,
freedroidRPG, scorched3d, etc...  The problem is that SDL is not
cooperating with arts sound server in KDE.  A simple work-around is to
terminate the arts sound server.  Perhaps SDL is not being compiled
with arts support???
Comment 2 Eli Wapniarski 2004-02-02 03:17:50 EST
Perhaps so..... As I said in my report, when I went to SDL's sight and replaced 
SDL with their RPM things worked fine. 
Comment 3 Christopher Stone 2004-02-03 15:36:14 EST
I tried upgrading to 1.2.6 with RPMs from the SDL site and this fixed
things, hopefully FC2 will use version 1.2.6.  Thanks for the notice.
Comment 4 Thomas Woerner 2004-02-05 11:22:10 EST
Please have a look at SDL-1.2.6-3.1 in rawhide. It should fix your
problems.
Comment 5 Dennis Gilmore 2004-02-13 19:35:08 EST
it doesnt work for me i can not play frozen-bubble or nethack  i can
by killing arts  there was no change put i noticed that SDL_mixer and
others were not updated
Comment 6 Christopher Stone 2004-02-13 19:41:22 EST
I think before you had to complete kill the arts server for it to
work, with the new version it should work if arts is just suspended. 
You can configure how long arts suspends itself from the kde control
center, I have mine set to like 10 seconds.
Comment 7 Dennis Gilmore 2004-02-13 22:03:03 EST
I understand that. I am running a 2.6.2 kernel with KDE 3.2 but had 
the same issues with 2.4 and KDE 3.1.4  i am using alsa as sound so 
it should always be available  arts doesnt stop access to the sound 
card. i have tried rebuilding SDL_mixer without any of the patches 
and that didnt help. 
Comment 8 Thomas Woerner 2004-02-23 10:50:14 EST
Please run the game in gdb and see where exactly it crashes.
Comment 9 Thomas Woerner 2004-10-07 10:13:12 EDT
Closed due to user inactivity.
Comment 10 Christopher Stone 2004-10-13 00:28:09 EDT
Hi sorry for putting this off.  Bug still occurs with latest rawhide
rpms (note there is no SDL_sound section in bugzilla)

Anyway here is the backtrace for a crash I get in dosbox (dosbox.sf.net):

#0  0xf5ec4440 in ?? ()
#1  0xf5d1929c in std::vector<Arts::MethodDef,
std::allocator<Arts::MethodDef> >::_M_insert_aux () from
/usr/lib/libmcop.so.1
#2  0xf5d194b6 in Arts::readTypeSeq<Arts::MethodDef> ()
   from /usr/lib/libmcop.so.1
#3  0xf5d116ef in Arts::InterfaceDef::readType () from
/usr/lib/libmcop.so.1
#4  0xf5d119c4 in Arts::InterfaceDef::InterfaceDef ()
   from /usr/lib/libmcop.so.1
#5  0xf5d1b58e in Arts::readTypeSeq<Arts::InterfaceDef> ()
   from /usr/lib/libmcop.so.1
#6  0xf5d127f9 in Arts::ModuleDef::readType () from /usr/lib/libmcop.so.1
#7  0xf5d12a76 in Arts::ModuleDef::ModuleDef () from /usr/lib/libmcop.so.1
#8  0xf5d3715a in Arts::IDLFileReg::startup () from /usr/lib/libmcop.so.1
#9  0xf5d3d3b7 in Arts::StartupManager::startup () from
/usr/lib/libmcop.so.1
#10 0xf5d23568 in Arts::Dispatcher::Dispatcher () from
/usr/lib/libmcop.so.1
#11 0xf41310a4 in arts_backend_init () from /usr/lib/libartscbackend.so.0
#12 0xf604e2b6 in arts_init () from /usr/lib/libartsc.so.0
#13 0xf6e9f53b in SDL_MixAudio_MMX_S8 () from /usr/lib/libSDL-1.2.so.0
#14 0xf6e9a661 in SDL_OpenAudio () from /usr/lib/libSDL-1.2.so.0
#15 0x080c23e4 in MIXER_Init (sec=0xa038568) at mixer.cpp:467
#16 0x080f293b in Config::Init (this=0xf5d63038) at stl_list.h:130
#17 0x080dc89c in main (argc=1, argv=0xfeff33f4) at sdlmain.cpp:1107


I also ran mamed and the exact same crash occured in the exact same
location, I imagine the crash is similar for other apps.  The mamed
developer says he runs mamed with SDL and does not get the crash, so
it appears to be a redhat specific bug.

Let me know if you need more info.

PS I tried to reopen this bug but couldn't.  I'll file a new bug if
required.
Comment 11 Christopher Stone 2004-10-13 19:04:27 EDT
setting SDL_AUDIODRIVER=arts fixes the crash.
Comment 12 Christopher Stone 2004-10-13 19:15:18 EDT
I should note that while setting SDL_AUDIODRIVER=arts fixes the crash,
the apps don't run with sound.

mamed gives this warning: Cannot open audio: No available audio device
and dosbox gives this warning: MIXER:Can't open audio: No available
audio device , running in nosound mode.

Perhaps SDL_mixer is not being compiled with arts support?
Comment 13 Thomas Woerner 2004-10-14 07:04:27 EDT
Fixed in rawhide in rpm SDL-1.2.7-8 or newer.
Comment 14 Christopher Stone 2004-10-15 14:35:46 EDT
Confirmed fixed! Thanks! :D

Note You need to log in before you can comment on or make changes to this bug.