Bug 113832 - kerenl symbol __generic_copy_to_user __generic_copy_from_user not exported in kernel 2.4.21-4.ELhugemem
kerenl symbol __generic_copy_to_user __generic_copy_from_user not exported in...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-19 03:13 EST by anand suvernkar
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-19 03:17:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description anand suvernkar 2004-01-19 03:13:58 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1)
Gecko/20020830

Description of problem:

The kernel symbols __generic_copy_to_user __generic_copy_from_user  
defined in the usercopy.c file in the kernel are
not exported  by the hugemem kernel. Due to this reason
any modules using these symbols isn failing to get loaded.
  What can be the problem ?
( In fact no symbol from usercopy.c is exported.
Given bellow is the list

c02a1e60 direct_strncpy_from_user_Rsmp_d4fd32ab
c02a1e20 __direct_strncpy_from_user_Rsmp_67e99ee3
c02a1ec0 direct_clear_user_Rsmp_b5e0f67b
c02a1f10 __direct_clear_user_Rsmp_6a9b2322
c02a1db0 __generic_copy_from_user_Rsmp_116166aa
c02a1d60 __generic_copy_to_user_Rsmp_d523fdd3
c02a1f30 direct_strnlen_user_Rsmp_37aed153


Thanks
Anand

Version-Release number of selected component (if applicable):
2.4.21-4.ELhugemem (kernel-hugemem-2.4.21-4.EL)

How reproducible:
Always

Steps to Reproduce:
1. Install the kernel-hugemem-2.4.21-4.EL rpm
2. check the /proc/ksyms for the above mentioned symbols
3.
    

Actual Results:  The above mentioned symbols are missing for the 
/proc/ksyms file

Expected Results:  The above mentioned symbols should be there in the
/proc/ksyms file

Additional info:
Comment 1 Arjan van de Ven 2004-01-19 03:17:00 EST
these functions don't even exist in this kernel.
Can you give an URL to the source of the module in question so that we
can see and help fixing ?
Comment 2 anand suvernkar 2004-01-19 05:03:10 EST
This is the file that defined the above functions.

/usr/src/linux-2.4.21-4.ELsmp/arch/i386/lib/usercopy.c

The functions copy_to_user , direct_copy_to_user calls this library
function.

I find the symbol in the /proc/ksyms for smp kernel but not for
the hugemem kernel
Thanks
anand
Comment 3 Arjan van de Ven 2004-01-19 05:05:28 EST
Please come back when you can answer the questions about the URL for
the source and such and not before that.
Comment 4 anand suvernkar 2004-01-19 05:14:08 EST
I have the source from the redhat RHEL 3.0 disk number 3
The package is
kernel-source-2.4.21-4.EL.i386.rpm
Thanks
Anand
Comment 5 Arjan van de Ven 2004-01-19 05:15:19 EST
I meant the source of your (obviously GPL) module, not the kernel source.

Note You need to log in before you can comment on or make changes to this bug.