Bug 1138333 - need mod_qos >= 10.29 for IPv6 clients
Summary: need mod_qos >= 10.29 for IPv6 clients
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: mod_qos
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Othman Madjoudj
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-04 14:11 UTC by Cristóbal Palmer
Modified: 2014-11-15 09:22 UTC (History)
2 users (show)

Fixed In Version: mod_qos-11.5-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-01 17:11:17 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Cristóbal Palmer 2014-09-04 14:11:19 UTC
Description of problem:

See upstream closed/fixed bug report:

http://sourceforge.net/p/mod-qos/bugs/24/

Version-Release number of selected component (if applicable):

Any build <= 10.29

How reproducible/Steps to Reproduce:

Deploy mod_qos on a host using packages from EPEL with a low QS_SrvMaxConnPerIP value (eg. 2). Connect from multiple IPv6-only hosts and observe that connections are rejected based on the collective number of connections between hosts, not based on the number of connections each individual host makes.

Again, see the upstream ticket.

Actual results:

Connections are rejected based on a collective-for-all-IPv6-hosts limit vs. a per-host limit.

Expected results:

Connections capped based on number of connections per host.

Comment 1 Cristóbal Palmer 2014-09-23 19:03:44 UTC
I've successfully used mod_qos-unc-11.5-3.el6.x86_64.rpm from this page <http://its2.unc.edu/dci_components/shared_apps/packages/repository/mod_qos/mod_qos-unc-11.5/> for several days. Stable and nothing troubling in the logs. A source rpm is available on that page that may or may not meet your needs.

Comment 2 Othman Madjoudj 2014-10-10 15:44:09 UTC
Hi Cristóbal

I'll update the package to 11.5, please test and provide karma in bodhi.

Comment 3 Fedora Update System 2014-10-10 16:13:11 UTC
mod_qos-11.5-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/mod_qos-11.5-1.fc21

Comment 4 Fedora Update System 2014-10-10 16:54:27 UTC
mod_qos-11.5-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mod_qos-11.5-1.fc20

Comment 5 Fedora Update System 2014-10-10 17:02:53 UTC
mod_qos-11.5-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/mod_qos-11.5-1.el6

Comment 6 Fedora Update System 2014-10-10 22:08:09 UTC
Package mod_qos-11.5-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing mod_qos-11.5-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-3260/mod_qos-11.5-1.el6
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2014-11-01 17:11:17 UTC
mod_qos-11.5-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2014-11-15 09:22:06 UTC
mod_qos-11.5-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.