Bug 113834 - Kickstart exits when 5 ethernet cards are defined in KS file
Kickstart exits when 5 ethernet cards are defined in KS file
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-19 05:08 EST by Johan De Wit
Modified: 2007-04-18 13:01 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-20 11:00:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johan De Wit 2004-01-19 05:08:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.2.1)
Gecko/20030711

Description of problem:
Kickstarting host with 5 ethernetcards.  Only a maximmum of 4 cards
seems to be supported.

The kickstart entry :

network --device eth0 --bootproto static --ip 138.203.8.10 \ 
        --netmask 255.255.252.0 --gateway 138.203.8.100  \
        --nameserver 138.203.8.79,138.203.9.115 --hostname bthx16
network --device eth1 --bootproto static --ip 192.168.10.01 \ 
        --netmask 255.255.255.0 
network --device eth2 --bootproto static --ip 192.168.20.01 \ 
        --netmask 255.255.255.0 
network --device eth3 --bootproto static --ip 192.168.30.01 \ 
        --netmask 255.255.255.0 
network --device eth4 --bootproto static --ip 192.168.40.01 \ 
        --netmask 255.255.255.0 

This results in the following error during KS install :

Traceback (most recent call last):
  File "/usr/bin/anaconda", line 705, in ?
    instClass.setInstallData(id)
  File "/usr/lib/anaconda/kickstart.py", line 1154, in setInstallData
    self.readKickstart(id, self.file)
  File "/usr/lib/anaconda/kickstart.py", line 668, in readKickstart
    handlers[args[0]](id, args[1:])
  File "/usr/lib/anaconda/kickstart.py", line 446, in doNetwork
    self.setNetwork(id, bootproto, ip, netmask, device=device)
  File "/usr/lib/anaconda/installclass.py", line 289, in setNetwork
    dev=devices[device]
KeyError: eth4
Install exited abnormally 
< systems halts >






Version-Release number of selected component (if applicable):
anaconda-9.0

How reproducible:
Always

Steps to Reproduce:
1. Installing using KSfile with 5 network entries
2.
3.
    

Actual Results:  Installation aborts, system halts

Expected Results:  installation should continue, and all ethernet
devices are properly configured.

Additional info:
Comment 1 Jeremy Katz 2004-01-19 09:35:28 EST
Do you actually have five supported ethernet cards in the machine? 
Comment 2 Johan De Wit 2004-01-20 09:55:05 EST
The problem is indded the last bcard is not recognized/configured
duting the installation.  After installation, it is no problem to
configure it properly.  Only eth0->eth3 are visible, which causes the
installation abort on eth4.  

The configuration ;
3 pci 3com 3c59x 
2 ISA 3com 3c5x9

All are working when configured manually after installation.

In the meantime I tried the following :

device eth 3c509 --options="xcvr=4,4 irq=10,5"
device eth 3c509 --options="xcvr=4 irq=5"

and via 
%pre 
#!/bin/sh
modprobe 3c509 xcvr=4 irq=10

Still hav  no success, but will add more comments doing some more
tests tomorrow.

Kernel options are no option. (yet)
Comment 3 Jeremy Katz 2004-01-20 11:00:25 EST
ISA network cards are not supported in the installer.
Comment 4 Johan De Wit 2004-01-21 02:35:59 EST
Solution - Dasbale PnP feature on all ISA based NIC

One of the nics was configured PnP.  
Solution :  Get the 3c5x9xxx.exe (ftp.scom/com/pub/nic/3c5x9/) 
            boot into dos and execute 3c5x9cfg.exe
            disable pnp, and check other config
            reboot and start installation.




Note You need to log in before you can comment on or make changes to this bug.