Bug 11385 - bzip2 should be split to bzip2 and bzip2-devel
bzip2 should be split to bzip2 and bzip2-devel
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: bzip2 (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-12 06:34 EDT by Michael Tokarev
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-16 11:20:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
diff for .spec file (package splitting mostly) (1.57 KB, patch)
2000-05-12 06:35 EDT, Michael Tokarev
no flags Details | Diff

  None (edit)
Description Michael Tokarev 2000-05-12 06:34:42 EDT
Bzip2 contains now two components -- bzip2 program itself, together
with shared lib, and development files (libbz2.a, libbz2.so, bzlib.h).
Like in zlib, I suggest to split this package into two parts.

Attached is a patch for bzip2.spec with that split.
Also I updated it to 1.0pre7 (source is in sourceware).

Some notes about 1.0.
RH's patch for makefile that was for 0.xxx to build and use shared
library is ok for 1.0pre7, but in that 1.0 there is new makefile
especially to build shared lib.  That last makefile is a bit strange
for me (looks like expiriment). (RH's patch for 0.x, as I said, is
ok for 1.0pre7).  But in that new makefile, .so has version 1.0.0,
but all previous versions used 0.0.0, and new version is binary
compatible.
So I in doubt what we should do with this -- author wants it to be
libbz2.so.1.0.0, all previous usages was .so.0.0.0, and new&old is
compatible, so there is no need to increment (major) version number...
If this increment will occur, all utilities (notable rpm) should be
relinked to use new .so file...

Also note that new "utilities" (bzmore, bzless) is useless since "less"
already have ability to deal with archives etc via lesspipe mechanism
(the same is true for gzip's zless).
Comment 1 Michael Tokarev 2000-05-12 06:35:59 EDT
Created attachment 241 [details]
diff for .spec file (package splitting mostly)
Comment 2 Trond Eivind Glomsrxd 2000-05-12 11:30:59 EDT
Thanks for the input. Splitting will be done when we put 1.0 in the tree (I
prefer not to use beta versions). As for building shared libraries, I autoconfed
and libtoolized the latest beta and sent the result to the author. I haven't
received any feedback from him yet, though.
Comment 3 Trond Eivind Glomsrxd 2000-05-16 11:20:59 EDT
I've split it into two packages, it should appear in some future rawhide.

Note You need to log in before you can comment on or make changes to this bug.