Bug 1138511 - win2012r2 guest bsod(DRIVER_POWER_STATE_FAILURE) when doing restart guest
Summary: win2012r2 guest bsod(DRIVER_POWER_STATE_FAILURE) when doing restart guest
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Gerd Hoffmann
QA Contact: Xujun Ma
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-05 03:52 UTC by ShupingCui
Modified: 2016-11-07 20:15 UTC (History)
16 users (show)

Fixed In Version: qemu-2.5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-07 20:15:26 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot (20.79 KB, application/octet-stream)
2014-09-05 03:57 UTC, ShupingCui
no flags Details
dump analysis with symbols (24.34 KB, text/plain)
2014-09-07 13:42 UTC, Yan Vugenfirer
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1058115 None None None Never
Red Hat Bugzilla 1139928 None None None Never
Red Hat Bugzilla 1171571 None None None Never
Red Hat Product Errata RHBA-2016:2673 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2016-11-08 01:06:13 UTC

Internal Links: 1058115 1139928 1171571

Description ShupingCui 2014-09-05 03:52:33 UTC
Description of problem:
win2012r2 guest bsod(DRIVER_POWER_STATE_FAILURE) when doing restart guest

Version-Release number of selected component (if applicable):
# uname -r
3.10.0-147.el7.x86_64
# rpm -q qemu-kvm-rhev
qemu-kvm-rhev-2.1.0-3.el7.x86_64


How reproducible:
2/4

Steps to Reproduce:
1. boot guest with ide and e1000 using '-M rhel6.5.0'
/usr/bin/qemu-kvm \
    -name 'virt-tests-vm1'  \
    -sandbox off  \
    -M rhel6.5.0  \
    -nodefaults  \
    -vga qxl  \
    -chardev socket,id=hmp_id_hmp1,path=/tmp/monitor-hmp1-20140904-180328-nwRqpEdK,server,nowait \
    -mon chardev=hmp_id_hmp1,mode=readline  \
    -chardev socket,id=serial_id_serial0,path=/tmp/serial-serial0-20140904-180328-nwRqpEdK,server,nowait \
    -device isa-serial,chardev=serial_id_serial0  \
    -chardev socket,id=seabioslog_id_20140904-180328-nwRqpEdK,path=/tmp/seabios-20140904-180328-nwRqpEdK,server,nowait \
    -device isa-debugcon,chardev=seabioslog_id_20140904-180328-nwRqpEdK,iobase=0x402 \
    -device ich9-usb-uhci1,id=usb1,bus=pci.0,addr=03 \
    -drive id=drive_image1,if=none,file=/mnt/nfs_images/win2012-64r2.qcow2 \
    -device ide-hd,id=image1,drive=drive_image1,bus=ide.0,unit=0 \
    -device e1000,mac=9a:de:01:cf:3e:f6,id=idw5ljsN,netdev=id2SL2dU,bus=pci.0,addr=04  \
    -netdev tap,id=id2SL2dU,vhost=on,vhostfd=25,fd=24  \
    -m 4096  \
    -smp 6,maxcpus=6,cores=1,threads=1,sockets=6  \
    -cpu 'SandyBridge' \
    -drive media=cdrom,file=/usr/local/autotest/tests/virt/shared/data/isos/windows/winutils.iso,bus=0,unit=1 \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1  \
    -spice port=3000,disable-ticketing  \
    -rtc base=localtime,clock=host,driftfix=none  \
    -boot order=cdn,once=c,menu=off \
    -enable-kvm

2. login guest and re-boot guest
3. re-peat step2 25 times

Actual results:
win2012r2 guest bsod(DRIVER_POWER_STATE_FAILURE)

Expected results:
win2012r2 guest reboot successfully and works well

Additional info:
host cpus:
processor	: 7
vendor_id	: GenuineIntel
cpu family	: 6
model		: 42
model name	: Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz
stepping	: 7
microcode	: 0x29
cpu MHz		: 3597.757
cache size	: 8192 KB
physical id	: 0
siblings	: 8
core id		: 3
cpu cores	: 4
apicid		: 7
initial apicid	: 7
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx lahf_lm ida arat epb xsaveopt pln pts dtherm tpr_shadow vnmi flexpriority ept vpid
bogomips	: 6784.38
clflush size	: 64
cache_alignment	: 64
address sizes	: 36 bits physical, 48 bits virtual
power management:

Comment 2 ShupingCui 2014-09-05 03:57:39 UTC
Created attachment 934682 [details]
screenshot

Comment 4 Ronen Hod 2014-09-07 06:36:07 UTC
Yan, assigning to you for any Windows-side insight. Then we will reassign.

Comment 5 Yan Vugenfirer 2014-09-07 13:42:42 UTC
Created attachment 935138 [details]
dump analysis with symbols

Comment 23 Gerd Hoffmann 2016-04-15 11:22:51 UTC
Please retest with qemu 2.5.0 or newer.

Commit ca5a21c40d95d7a4e26ea0a304fd2cd8ad4e6ae1 possibly fixes this one.

Comment 24 ShupingCui 2016-04-19 02:09:33 UTC
(In reply to Gerd Hoffmann from comment #23)
> Please retest with qemu 2.5.0 or newer.
> 
> Commit ca5a21c40d95d7a4e26ea0a304fd2cd8ad4e6ae1 possibly fixes this one.

Yes, cannot reproduce this bug on host(3.10.0-370.el7.x86_64, qemu-kvm-rhev-2.5.0-4.el7.x86_64) with 100 times.

Comment 27 Yiqian Wei 2016-09-12 08:19:53 UTC
 I retest,this bug cannot reproduce 100%.

1.Version:
  host:kernel-3.10.0-505.el7.x86_64
       qemu-kvm-rhev-2.1.2-23.el7.x86_64
  guest:win2012r2
2.Version:
  host:kernel-3.10.0-505.el7.x86_64
       qemu-kvm-rhev-2.6.0-23.el7.x86_64
  guest:win2012r2

Test step:
1.boot a guest 
/usr/libexec/qemu-kvm \
-name 'virt-tests-vm1'  \
-sandbox off  \
-M pc  \
-nodefaults  \
-vga qxl  \
-global qxl-vga.vram_size=33554432  \
-chardev socket,id=qmp_id_qmpmonitor1,path=/tmp/monitor-qmpmonitor1-20141024-125111-W1muM4Pe,server,nowait \
-mon chardev=qmp_id_qmpmonitor1,mode=control  \
-chardev socket,id=serial_id_serial0,path=/tmp/serial-serial0-20141024-125111-W1muM4Pe,server,nowait \
-device isa-serial,chardev=serial_id_serial0  \
-chardev socket,id=seabioslog_id_20141024-125111-W1muM4Pe,path=/tmp/seabios-20141024-125111-W1muM4Pe,server,nowait \
-device isa-debugcon,chardev=seabioslog_id_20141024-125111-W1muM4Pe,iobase=0x402 \
-device ich9-usb-uhci1,id=usb1,bus=pci.0,addr=0x3 \
-drive id=drive_image1,if=none,cache=none,snapshot=off,aio=native,file=/root/win2012r2/test-1.qcow2 \
-device ide-hd,id=image1,drive=drive_image1,bus=ide.0,unit=1 \
-device e1000,mac=9a:6d:6e:6f:70:72,id=idiBPuRb,netdev=idljrhW9,bus=pci.0,addr=0x4 \
-netdev tap,id=idljrhW9  \
-m 8192  \
-smp 4,cores=2,threads=1,sockets=2  \
-cpu 'SandyBridge',+kvm_pv_unhalt,hv_relaxed,hv_spinlocks=0x1fff,hv_vapic,hv_time \
-spice port=3001,disable-ticketing  \
-rtc base=localtime,clock=host,driftfix=slew  \
-boot order=cdn,once=c,menu=off \
-device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1  \
-enable-kvm \
-monitor stdio \
-drive file=/root/win2012r2/en_windows_server_2012_r2_x64_dvd_2707946.iso,media=cdrom \

2. login guest and re-boot guest
3. re-peat step2 100 times

Test results:
win2012r2 guest reboot successfully,no bsod.

Comment 30 errata-xmlrpc 2016-11-07 20:15:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2673.html


Note You need to log in before you can comment on or make changes to this bug.