Bug 1138619 - libguestfs-1.27.36-2.fc22: FTBFS with Perl 5.20
Summary: libguestfs-1.27.36-2.fc22: FTBFS with Perl 5.20
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libguestfs
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard W.M. Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-05 10:27 UTC by Jitka Plesnikova
Modified: 2014-09-15 13:23 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-15 13:23:46 UTC
Type: Bug


Attachments (Terms of Use)
build.log (7.76 KB, text/plain)
2014-09-05 10:27 UTC, Jitka Plesnikova
no flags Details
build.log (2.68 MB, text/plain)
2014-09-05 10:29 UTC, Jitka Plesnikova
no flags Details
root.log (186.87 KB, text/plain)
2014-09-05 10:30 UTC, Jitka Plesnikova
no flags Details

Description Jitka Plesnikova 2014-09-05 10:27:09 UTC
Created attachment 934729 [details]
build.log

libguestfs can't be rebuilt against perl 5.20, because tests failed.


...

libguestfs: trace: internal_autosync = 0
libguestfs: calling virDomainDestroy "guestfs-vnb41qtdgfel2f8g" flags=0
libguestfs: command: run: rm
libguestfs: command: run: \ -rf /builddir/build/BUILD/libguestfs-1.27.36/tmp/libguestfsQVaL3T
kernel: /boot/vmlinuz-3.17.0-0.rc3.git1.1.fc22.x86_64
/builddir/build/BUILD/libguestfs-1.27.36/run: command failed with exit code 2
FAIL: test-syslinux.sh
105 seconds: ./test-extlinux.sh
PASS: test-extlinux.sh
===================
1 of 2 tests failed
===================
Makefile:1451: recipe for target 'check-TESTS' failed
make[2]: Leaving directory '/builddir/build/BUILD/libguestfs-1.27.36/tests/syslinux'
make[2]: *** [check-TESTS] Error 1
make[1]: *** [check-am] Error 2
make[1]: Target 'check' not remade because of errors.
Makefile:1574: recipe for target 'check-am' failed

Comment 1 Jitka Plesnikova 2014-09-05 10:29:41 UTC
Created attachment 934731 [details]
build.log

Comment 2 Jitka Plesnikova 2014-09-05 10:30:08 UTC
Created attachment 934732 [details]
root.log

Comment 3 Richard W.M. Jones 2014-09-05 10:51:15 UTC
Note this is the old version.  1.27.37 also has a bug in one
of the tests which causes a build failure, but 1.27.38 (likely
released today) should fix it.

Comment 4 Richard W.M. Jones 2014-09-06 08:03:24 UTC
Successful build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=7532299

Comment 5 Richard W.M. Jones 2014-09-08 20:22:23 UTC
Well that's really strange ...

http://koji.fedoraproject.org/koji/taskinfo?taskID=7542185

Can you try the build again?  I suspect it might be an LVM
regression.  Cannot imagine how it's related to Perl.

Comment 6 Richard W.M. Jones 2014-09-09 12:35:48 UTC
https://kojipkgs.fedoraproject.org//work/tasks/3521/7553521/build.log

This one is a real udev bug I've been trying to track down
for days.  No BZ yet as it's very difficult to reproduce except
in Koji.

Comment 7 Petr Pisar 2014-09-15 13:08:57 UTC
It's not related to perl 5.20 (first successful koji build against perl 5.20 is libguestfs-1.27.41-1.fc22). It failed even with perl 5.18 (https://ppisar.fedorapeople.org/perl_rebuild/scratch/index.xhtml#plibguestfs).

Comment 8 Richard W.M. Jones 2014-09-15 13:23:46 UTC
Seems to be fixed now anyway:
http://koji.fedoraproject.org/koji/buildinfo?buildID=577152


Note You need to log in before you can comment on or make changes to this bug.