This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 113865 - Reading partition table on some usb keys
Reading partition table on some usb keys
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-19 11:42 EST by Leon Bottou
Modified: 2007-04-18 13:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:41:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leon Bottou 2004-01-19 11:42:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux; X11; i686)

Description of problem:
This might indicate some bug in the partition table reading code.

I have a cheap usb key (sandisk mini cruzer 128M - SDCZ2-128)
After buying the key, I noticed that it would cause
a kernel crash in mandrake but work under redhat.
Switched mandrake for redhat-9.

Lately, I updated to kernel 2.4.20-28.[789] and
got the same crashes as Mandrake.  I googled for
solutions and found a small message saying
that making two partitions sometimes helps.

I rebooted the old kernel, ran fdisk to create two
partitions instead of just one.  Now my key seems to 
work everywhere (mandrake, redhat including 2.4.20-28).

Question: is there a bug somewhere 
in the partition table reading?


Version-Release number of selected component (if applicable):
kernel-2.4.20-28.[789]

How reproducible:
Always

Steps to Reproduce:
I tried this using 
- A fujitsu S4542 laptop running RH7.3  (P3m-600M)
- A dell precision 340 (P4-1.8G-Intel850) running RH8.0
- A shuttle SS51G (P4-2G-SIS651+962)  [usb2]


1. Get a USB key Sandisk Mini Cruzer 128M  (SDCZ2-128)
2. Plug with kernel 2.4.20-28.[789]  (kernel crash)
3. Plug with kernel 2.4.20-27.[789]  (works!)
4. Repartition with fdisk.
     - one vfat partition with 249 cylinders
     - one ext2 partition with 1 cylinder (512Kb)
5. Plug with kernel 2.4.20-28.[789]  (works now!)



Additional info:
Comment 1 Bugzilla owner 2004-09-30 11:41:47 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.