Bug 1138675 - subscription-manager exits 1 even when registration succeeds
Summary: subscription-manager exits 1 even when registration succeeds
Keywords:
Status: CLOSED DUPLICATE of bug 1132981
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: candlepin-bugs
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel66
TreeView+ depends on / blocked
 
Reported: 2014-09-05 12:23 UTC by Stephen Benjamin
Modified: 2014-09-09 14:15 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-09 14:15:02 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Stephen Benjamin 2014-09-05 12:23:15 UTC
Description of problem:
When registering a host with an activation key, subscription manager reports "No products installed." and exits with an error, even though registration succeeds


Version-Release number of selected component (if applicable):
This happens against Katello 2.0 nightlies and subscription-manager-1.12.14-1.el6.x86_64.rpm  

How reproducible:
Always

Steps to Reproduce:
1.  Have a content view in Katello with a repo such as 'Zoo':
  https://repos.fedorapeople.org/repos/pulp/pulp/demo_repos/zoo/
2. Create an AK against this published CV
3. Try to register a system w/ the AK

Actual results:
[root@katello-bats-1409910676 katello-deploy]# subscription-manager register --force --org="Default_Organization" --activationkey="Test AK"
The system has been registered with ID: 264f47ab-47c3-4f4a-8d33-2b0bab63b8f0
No products installed.
[root@katello-bats-1409910676 katello-deploy]# echo $?
1
[root@katello-bats-1409910676 katello-deploy]# subscription-manager repos
+----------------------------------------------------------+
Available Repositories in /etc/yum.repos.d/redhat.repo
+----------------------------------------------------------+
Repo ID:   Default_Organization_Test_Product_Zoo
Repo Name: Zoo
Repo URL:  https://katello-bats-1409910676.novalocal/pulp/repos/Default_Organization/Test/Test_CV/custo/Test_Product/Zoo
Enabled:   1


Expected results:
Exits with '0' and no error message

Comment 2 Stephen Benjamin 2014-09-09 14:15:02 UTC

*** This bug has been marked as a duplicate of bug 1132981 ***


Note You need to log in before you can comment on or make changes to this bug.