Bug 1138688 - [windows] unable to log in to JON from FF [NEEDINFO]
Summary: [windows] unable to log in to JON from FF
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: UI
Version: JON 3.3.0
Hardware: x86_64
OS: Windows
urgent
urgent
Target Milestone: ER05
: JON 3.3.0
Assignee: Libor Zoubek
QA Contact: Armine Hovsepyan
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-05 13:03 UTC by Armine Hovsepyan
Modified: 2015-11-02 00:44 UTC (History)
11 users (show)

(edit)
It was discovered that if the Mozilla Firefox browser clock was out of sync with the server clock by a large amount of time, the user was not able to log in because the session timeout immediately logged the user out of the UI. The fix now correctly synchronizes the computers clocks correctly, which allows users to log in correctly.
Clone Of:
(edit)
Last Closed: 2014-12-11 14:00:33 UTC
lzoubek: needinfo? (jmorgan)


Attachments (Terms of Use)
win_login (1.49 MB, application/octet-stream)
2014-09-05 13:03 UTC, Armine Hovsepyan
no flags Details
win_login_crome (679.73 KB, application/octet-stream)
2014-09-05 13:04 UTC, Armine Hovsepyan
no flags Details
windows_login_er05 (108.30 KB, image/png)
2014-10-22 09:13 UTC, Armine Hovsepyan
no flags Details
win_ff_login (57.27 KB, image/png)
2014-10-24 14:59 UTC, Armine Hovsepyan
no flags Details

Description Armine Hovsepyan 2014-09-05 13:03:33 UTC
Created attachment 934773 [details]
win_login

Description of problem:
[windows] unable to log in to JON from FF (versions 23 and 32 checked)

Version-Release number of selected component (if applicable):
JON 3.3 ER02

How reproducible:
always

Steps to Reproduce:
1. log in to JON GUI from firefox on w2008 
2. log in to JON GUI from chrome on w2008 
3.

Actual results:
after step1. cannot log in -- no error on gui, no log on server & agent logs
after step2. log in to gui -- URL is changed from IP:7080/coregui/login to IP:7080/coregui/login#Dashboard

Expected results:
log in to gui -- URL is changed from IP:7080/coregui/login to IP:7080/coregui#Dashboard

Additional info:
screen-shots attached

Comment 1 Armine Hovsepyan 2014-09-05 13:04:49 UTC
Created attachment 934774 [details]
win_login_crome

Comment 2 Stefan Negrea 2014-09-05 14:23:31 UTC
The screenshot is not conclusive. In attachment 934774 [details], I see that you are logged in both browsers. 

Can you provide more details and additional screenshots? Is it possible that you were already logged in prior to the step 1? Can you please try on a clean w2008 system?

Comment 4 Stefan Negrea 2014-09-05 15:45:30 UTC
Worked with Armine to reproduce but without success; tried this on 2 separate Windows machines. It could have been a caching issue on the intial box.

However, we uncovered that the login screen does not look good on low screen resolution. 


Armine, can you please close this BZ and open a new focused only on the login page layout at low resolutions?

Comment 5 Stefan Negrea 2014-09-05 18:14:43 UTC
The issue with the login page layout at low resolutions was captured already in bug 1135018.


Please close this bug if there are no futher issues to investigate.

Comment 6 Armine Hovsepyan 2014-09-08 07:21:57 UTC
There must have been a missunderstanding.
In firefox, in Win 2008 server i am still unable to log in to JON. Cleaning cache does not fix this issue.
 The issue is still valid. moving back to assigned.

Comment 7 Stefan Negrea 2014-09-08 17:29:06 UTC
Armine, can you please post a new screenshot? The current one does not give any indication of what the problem is.

Comment 9 Armine Hovsepyan 2014-09-09 08:19:39 UTC
video with reproduction attached

Comment 10 Simeon Pinder 2014-09-29 08:12:56 UTC
Moving into ER05 as didn't make the ER04 cut.

Comment 13 Jirka Kremser 2014-10-14 23:43:11 UTC
Cannot reproduce the FF issue on:
VirtualBox:
 Windows 8.1 and FF23 FF32 FF33 (none of them)
 Windows XP FF33

BrowserStack:
 Windows 7 FF23 FF32 FF33


However, I reproduced the Chrome issue on w8.1, Chrome40dev using BrowserStack and even on my box, so I'll address this.

Comment 15 Jirka Kremser 2014-10-16 16:45:54 UTC
branch:  master
link:    https://github.com/rhq-project/rhq/commit/9e915a46d
time:    2014-10-16 17:48:50 +0200
commit:  9e915a46d700b5a26777cdc82d83eb8f44b28760
author:  Jirka Kremser - jkremser@redhat.com
message: [BZ 1138688] - [windows] unable to log in to JON from FF - adding some
         magic to make the logging in working on newer browsers.
         Basically, some waiting (20ms) needed to be added before the
         redirect. Because of the fact that /login and /Coregui.html
         both uses the same gwt module some logic was added to
         distinguish between them and prevent the UI from rendering when
         user is still on the /login page.

Comment 16 Jirka Kremser 2014-10-16 16:54:00 UTC
branch:  release/jon3.3.x
link:    https://github.com/rhq-project/rhq/commit/1cb21219e
time:    2014-10-16 18:48:28 +0200
commit:  1cb21219e54eb156668d02f9829d61fe4b1531b4
author:  Jirka Kremser - jkremser@redhat.com
message: [BZ 1138688] - [windows] unable to log in to JON from FF - adding some
         magic to make the logging in working on newer browsers.
         Basically, some waiting (20ms) needed to be added before the
         redirect. Because of the fact that /login and /Coregui.html
         both uses the same gwt module some logic was added to
         distinguish between them and prevent the UI from rendering when
         user is still on the /login page.

         (cherry picked from commit
         9e915a46d700b5a26777cdc82d83eb8f44b28760) Signed-off-by: Jirka
         Kremser <jkremser@redhat.com>

Comment 17 Jay Shaughnessy 2014-10-16 18:24:22 UTC
release/jon3.3.x commit 412c0a1a87c4641271e14dabf6ddeb9c948df602
Author: Jay Shaughnessy <jshaughn@redhat.com>
Date:   Thu Oct 16 14:20:13 2014 -0400

    [1138688] Fix cherry-pick issue that lost necessary import

Comment 18 Simeon Pinder 2014-10-21 20:24:35 UTC
Moving to ON_QA as available to test with the latest brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=394734

Comment 20 Armine Hovsepyan 2014-10-22 09:13:34 UTC
Created attachment 949306 [details]
windows_login_er05

Comment 21 Libor Zoubek 2014-10-23 15:45:56 UTC
Could not reproduce either, but the issue happens only if browser machine has incorrect time set (I am able to reproduce if time is set +- 8hours further).

Not sure if I am able to fix this (the fact, that we require the client to have correct time+time zone set).

Comment 23 Armine Hovsepyan 2014-10-24 14:58:21 UTC
Libor fixed the time sync on my windows env -- thank you Libor.

Comment 24 Armine Hovsepyan 2014-10-24 14:59:14 UTC
Created attachment 950402 [details]
win_ff_login


Note You need to log in before you can comment on or make changes to this bug.