Bug 113876 - Interface does not provide a 3D Hardware Acceleration Enabled checkbox
Summary: Interface does not provide a 3D Hardware Acceleration Enabled checkbox
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-config-xfree86
Version: 1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-19 19:36 UTC by Paolo Prandini
Modified: 2007-11-30 22:10 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2004-01-19 19:53:10 UTC


Attachments (Terms of Use)

Description Paolo Prandini 2004-01-19 19:36:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
A check box helping to enable 3D Hardware Acceleration (DRI) should
appeare somewhere in the interface, but it's not there.
The obvious walkaround is to edit XF86Config by hand, but RH9 had this
feature so it's good to have it in Fedora Core 1 as well.

Version-Release number of selected component (if applicable):
redhat-config-xfree86-0.9.15-1

How reproducible:
Always

Steps to Reproduce:
1. launch redhat-config-xfree86
2. no check box for 3D Hardware Acceleration is there 

    

Actual Results:  I cannot add 3D HW Acceleration from the GUI.

Expected Results:  A way should be provided to add 3D Hardware
Acceleration from the GUI

Additional info:

None

Comment 1 Brent Fox 2004-01-19 19:53:10 UTC
We removed the checkbox because people would enable it for cards that
3D doesn't work on and it would hard-lock their systems.  The right
thing to do is for the tool to automatically enable it for the cards
that 3D is known to work for and automatically disable it for the
cards that are known to not work in 3D.  

We have a list of cards for which 3D should not be used.  We need to
keep this list current so that if drivers get fixed in the future,
then 3D will be enabled on those cards.



Comment 2 Paolo Prandini 2004-01-21 07:04:42 UTC
Thank you.
Got the point.

Regards

- Paolo

PS : Go on with fantastic Fedora development !


Note You need to log in before you can comment on or make changes to this bug.