Bug 113880 - Network install with tg3 fails in FC development (but worked with FC1)
Network install with tg3 fails in FC development (but worked with FC1)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-19 15:14 EST by Anders Kaseorg
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-15 17:29:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anders Kaseorg 2004-01-19 15:14:45 EST
My laptop has a BCM5705 ethernet adapter (tg3) and a Prism 2.5
wireless adapter (orinoco_pci). I did a network install of FC1 using
PXE, and it worked fine. But the development version network installer
isn't working. After selecting the HTTP installation method, it tells
me I have multiple network cards -- which is true, though I didn't see
this in FC1 -- and asks me to install from either "eth - Unknown
vendor|Unknown device 1260:3873" or "eth - Broadcom
Corporation|unknown device 14e4:1653". I pick the latter. Then I
select DHCP in the following TCP/IP configuration screen, but the OK
button just flashes a box on the screen much faster than the refresh
rate allows me to see. VC3 says:
  * waiting for link...
  * 0 seconds.
  * pump told us: SIOCSIFADDR: No such device
and VC4 says:
  <7>request_module: failed /sbin/modprobe -- eth. error = -16
(Going back and picking the other network card gave the same error,
though orinoco_pci doesn't seem to be supported anyway.)
Comment 1 Jeremy Katz 2004-01-20 18:10:46 EST
What's the date on those images?  This *should* be fixed with current
versions of rawhide (work for me at least... :)
Comment 2 Anders Kaseorg 2004-01-21 11:37:44 EST
I still have the same problem with the latest version on
download.fedora.redhat.com (images/pxeboot/vmlinuz and
images/pxeboot/initrd.img, FTP timestamp 2004-01-21 10:37:00).
Comment 3 Jeremy Katz 2004-01-22 17:33:39 EST
Can you try this once the 2004-01-23 tree gets synced down?  (Before
that, there's lots of weirdness, but I fixed quite a bit today :)

If it doesn't work, can you md5sum the boot.iso just to make sure
we're talking about the same tree
Comment 4 Anders Kaseorg 2004-01-23 17:25:49 EST
Still the same problem. I'm not using boot.iso, just vmlinuz and
initrd.img from images/pxeboot:

fce04a7581629e5833bd81f87dc8ced8  vmlinuz
f6d80520cdbc6b83b3e92771b8ef6e7a  initrd.img
Comment 5 Jeremy Katz 2004-02-17 18:43:57 EST
Was this fixed in test1?  (Note that you will want to use selinux=0 if
you're pxe booting with a tg3 in test1)
Comment 6 Anders Kaseorg 2004-02-17 20:44:38 EST
No, it still doesn't work in the current development version (or do
you want me to try the actual test1?). The only difference is that the
error from VC4 no longer appears.

BTW, I got a better glimpse of the dialog it flashes on the screen,
and I think it says "Sending request for IP information for eth...".

975b543426e620b514d17dc408790160  vmlinuz
8a03bfcb516bd754268930b01cfd0da5  initrd.img
Comment 7 Jeremy Katz 2004-04-15 00:40:40 EDT
Does this happen with test2 or later?
Comment 8 Anders Kaseorg 2004-04-15 10:25:36 EDT
With test2 I don't even get a choice of which network card to use.
This had the happy side effect of making it work, but I don't know if
the bug was fixed.

I can't try out development now because the images/ directory is
empty. I hope it's coming back soon?
Comment 9 Jeremy Katz 2004-04-15 17:29:34 EDT
It'll be the tg3 -- we don't support installs over wireless and now
that I don't probe cards that we don't have a driver loaded for,
things are working exactly as I'd expect :)

Note You need to log in before you can comment on or make changes to this bug.