Bug 1138855 - EAP Patch Deploy To EAP Domain Controller Group Fails
Summary: EAP Patch Deploy To EAP Domain Controller Group Fails
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- Other
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ER03
: JON 3.3.0
Assignee: RHQ Project Maintainer
QA Contact: Mike Foley
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: JON3-10, PRODMGT-544
TreeView+ depends on / blocked
 
Reported: 2014-09-05 19:40 UTC by Matt Mahoney
Modified: 2014-12-11 14:03 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-12-11 14:03:08 UTC


Attachments (Terms of Use)
server.log (1017.06 KB, text/plain)
2014-09-05 19:40 UTC, Matt Mahoney
no flags Details

Description Matt Mahoney 2014-09-05 19:40:33 UTC
Created attachment 934901 [details]
server.log

Description of problem:
Deploy fails when attempting deploying a Patch Bundle to a Group that contains a single EAP Domain Controller (reproduced with 6.2.3 and 6.2.4 patch bundles).


Version-Release number of selected component (if applicable):
JON 3.3 ER02

How reproducible:
Always.

Steps to Reproduce:
1. Create a Group with a single EAP Domain Controller Resource.
2. Attempt to Deploy a 6.2.3 or 6.2.4 patch bundle to the EAP group.
3.

Actual results:
Deploy to a group containing EAP Domain Controllers.

Expected results:
Deploy to group containing EAP Domain Controllers should succeed.

Additional info:

Comment 1 Lukas Krejci 2014-09-08 13:30:34 UTC
master:
commit a4a608c90c90d3cddec7929c7d8cee83be8469b9
Author: Lukas Krejci <lkrejci@redhat.com>
Date:   Mon Sep 8 15:23:11 2014 +0200

    [BZ 1069547] Support shutdown of domain controller in ServerControl
    
    This fixes the patching domain controllers which failed if restart
    was demanded during the deployment.
    
    Also optimized the reading of host.xml (to find the host of the domain
    controller in the domain) to use SAX parser instead of DOM. This is
    much lighter on resources and should also be much quicker because we
    only need to read first couple of lines of the file.

release/jon3.3.x:
commit bf0d3cd8e02b223cdaee1d6721e444a965676043
Author: Lukas Krejci <lkrejci@redhat.com>
Date:   Mon Sep 8 15:23:11 2014 +0200

    [BZ 1069547] Support shutdown of domain controller in ServerControl
    
    This fixes the patching domain controllers which failed if restart
    was demanded during the deployment.
    
    Also optimized the reading of host.xml (to find the host of the domain
    controller in the domain) to use SAX parser instead of DOM. This is
    much lighter on resources and should also be much quicker because we
    only need to read first couple of lines of the file.
    
    (cherry picked from commit a4a608c90c90d3cddec7929c7d8cee83be8469b9)

Comment 3 Simeon Pinder 2014-09-17 02:49:14 UTC
Moving to ON_QA as available for test with the following brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=385149


Note You need to log in before you can comment on or make changes to this bug.