Bug 1138873 - Bad return code upon failed repo sync
Summary: Bad return code upon failed repo sync
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Pulp
Classification: Retired
Component: rpm-support
Version: 2.4.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: ---
Assignee: pulp-bugs
QA Contact: pulp-qe-list
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-05 21:21 UTC by Sean Waite
Modified: 2015-02-28 22:18 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-28 22:18:44 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Pulp Redmine 515 0 None None None Never

Description Sean Waite 2014-09-05 21:21:29 UTC
Description of problem:

When running "pulp-admin rpm repo sync run" against a repo with a bad URL in it's --feed option, pulp-admin returns 0.


Version-Release number of selected component (if applicable):
pulp-server-2.4.0-1.el6.noarch

CentOS release 6.5 (Final)


How reproducible:

100%

Steps to Reproduce:
1. Create a repo with a bogus URL in it's --feed
2. Run the sync
3. Watch it bail out

Actual results:

-bash-4.1# pulp-admin rpm repo create --repo-id dummy --feed http://www.asrcdyasrco.com
-bash-4.1# pulp-admin rpm repo sync run --repo-id dummy
+----------------------------------------------------------------------+
                    Synchronizing Repository [dummy]
+----------------------------------------------------------------------+

This command may be exited via ctrl+c without affecting the request.


Downloading metadata...
[-]
... failed

HTTPConnectionPool(host='www.asrcdyasrco.com', port=80): Max retries exceeded
with url: /repodata/repomd.xml (Caused by <class 'socket.gaierror'>: [Errno -2]
Name or service not known)


Task Failed

Importer indicated a failed response

-bash-4.1# echo $?
0



Expected results:

Return code should be non-zero to indicate failure.

Comment 1 Brian Bouterse 2015-02-28 22:18:44 UTC
Moved to https://pulp.plan.io/issues/515


Note You need to log in before you can comment on or make changes to this bug.