Bug 1138967 - UI won't permit adding new mountpoint to existing Btrfs, nor creation of a new filesystem to replace it
Summary: UI won't permit adding new mountpoint to existing Btrfs, nor creation of a ne...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F21BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2014-09-06 21:19 UTC by Chris Murphy
Modified: 2014-09-24 17:12 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-24 17:12:28 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
anaconda.log (14.76 KB, text/plain)
2014-09-06 21:21 UTC, Chris Murphy
no flags Details
program.log (22.87 KB, text/plain)
2014-09-06 21:21 UTC, Chris Murphy
no flags Details
storage.log (164.09 KB, text/plain)
2014-09-06 21:22 UTC, Chris Murphy
no flags Details
storage.state (20.00 KB, application/octet-stream)
2014-09-06 21:22 UTC, Chris Murphy
no flags Details

Description Chris Murphy 2014-09-06 21:19:28 UTC
Description of problem: Two problems, one of them is a bug. When I try to create a root mount point on an existing Btrfs volume, I'm told a new file system needs to be created. This is a regression in that previous installers would create a new "root(n)" subvolume to meet this new fs requirement. But if I accept this as designed, the next problem is that I can't actually create a new fs because all UI options including reformat are grayed out.

Version-Release number of selected component (if applicable):
anaconda-21.48.4-1.fc21.i686
python-blivet-0.62-1.fc21.noarch

How reproducible:
Always

Steps to Reproduce:
1. In custom partitioning, click on existing Btrfs volume under Unknown listing.
2. Click the Mount Point field, type /, click Update Settings.

A banner appears at the bottom that says "You must create a new file system on the root device."



Actual results:

The UI doesn't allow me to either create a new subvolume, or new file system on this partition.

Expected results:

Either it should create a new subvolume to meet the requirement as past installers did; or the UI needs to allow me to reformat the partition.

Additional info:

Comment 1 Chris Murphy 2014-09-06 21:21:38 UTC
Created attachment 935075 [details]
anaconda.log

Comment 2 Chris Murphy 2014-09-06 21:21:55 UTC
Created attachment 935076 [details]
program.log

Comment 3 Chris Murphy 2014-09-06 21:22:08 UTC
Created attachment 935077 [details]
storage.log

Comment 4 Chris Murphy 2014-09-06 21:22:38 UTC
Created attachment 935078 [details]
storage.state

Comment 5 Fedora Blocker Bugs Application 2014-09-06 21:43:59 UTC
Proposed as a Blocker for 21-beta by Fedora user chrismurphy using the blocker tracking app because:

 Beta criteria: When using the custom partitioning flow, the installer must be able to correctly interpret, and modify as described below, any disk with a valid ms-dos or gpt disk label and partition table containing ext4 partitions, LVM and/or btrfs volumes, and/or software RAID arrays at RAID levels 0, 1 and 5 containing ext4 partitions.

Note: It is possible to delete (minus button) the partition, and create a new one as a work around. But I can't modify it. If it's intentional that new Btrfs volumes need to be created to hold root fs, not merely a new subvolume, it can be argued this isn't a beta blocker. But would be a final blocker because "The installer must be able to create and install to any workable partition layout using any file system and/or container format combination offered in a default installer configuration." Since it offers UI to reformat, I should be allowed to do that.

Comment 6 Chris Murphy 2014-09-13 02:34:50 UTC
This is working as expected in anaconda-21.48.6-1.fc21.i686.

Comment 7 Kamil Páral 2014-09-24 17:12:28 UTC
If it works now, let's just close it.


Note You need to log in before you can comment on or make changes to this bug.