Bug 113910 - boot.iso installer segfaults signal 11 for CJK install
boot.iso installer segfaults signal 11 for CJK install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Eido INOUE
: i18n
: 116254 131081 (view as bug list)
Depends On:
Blocks: FC3Blocker
  Show dependency treegraph
 
Reported: 2004-01-19 20:33 EST by Jens Petersen
Modified: 2007-11-30 17:10 EST (History)
9 users (show)

See Also:
Fixed In Version: 10.1.0.0-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-21 14:45:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
modified spec file.diff (1.65 KB, patch)
2004-07-05 01:24 EDT, Akira TAGOH
no flags Details | Diff
a patch to replace bogl-0.1.9-rh.patch (25.66 KB, patch)
2004-07-05 01:25 EDT, Akira TAGOH
no flags Details | Diff

  None (edit)
Description Jens Petersen 2004-01-19 20:33:00 EST
Description of problem:
When doing an install from boot.iso, selecting
Japanese causes the installer to segfault with
signall 11 and shutdown.

Version-Release number of selected component (if applicable):
anaconda-9.3-0.20040114155239
kernel-2.6.1-1.47

How reproducible:
every time

Additional info:
Jeremy said "vga16fb is hosed".
Comment 1 Mike McLean 2004-01-21 16:11:11 EST
With rawhide-20040121 the behavior has changed.  The system no longer
shuts down.  Instead it simply stops (text screen changes background
color to red and then nothing happens).

Attempting to switch between VCs leads to screen corruption.
Comment 2 Jeremy Katz 2004-01-22 18:11:02 EST
Has the way framebuffers as modules work changed?  Loading vga16fb
doesn't seem to automatically change the console as happened with 2.4
Comment 3 Mike McLean 2004-01-22 18:42:14 EST
Hmm, yeah, I see this too with rawhide-20040122.  The install is just
stuck with the initial blue background screen scrolled up a few lines.
 I see no text though, as though loader error messages were written in
an invisible font.
Comment 4 Dave Jones 2004-01-22 20:06:15 EST
> Has the way framebuffers as modules work changed?

oh boy, where to begin..
looks like yet another regression in this area.

Comment 5 Jens Petersen 2004-02-03 20:04:03 EST
Should this be re-assigned to the kernel?
Comment 6 Jeremy Katz 2004-02-03 23:11:07 EST
No, fbdev has changed behavior in 2.6, I talked with the upstream
maintainer.  Now I get to change bogl to match.  
Comment 7 Jeremy Katz 2004-02-17 20:47:49 EST
Should be fixed with newer bogl + anaconda rebuild afterwards.
Comment 8 Mike McLean 2004-02-19 16:48:00 EST
*** Bug 116254 has been marked as a duplicate of this bug. ***
Comment 9 Jens Petersen 2004-02-20 09:35:13 EST
Thanks.  Confirmed fixed in latest tree.
Comment 10 Jens Petersen 2004-02-20 09:55:15 EST
Errm, the initial segfault is gone, but now it segfaults
before "starting X" even with "linux text selinux=0"
I'm afraid.
Comment 11 Bill Nottingham 2004-02-20 10:29:04 EST
Laptop w/pcmcia?
Comment 12 Jens Petersen 2004-02-20 13:36:10 EST
Nope, Dell Dimension 2400c, and Dell Precision 450.
Comment 13 Nakai 2004-02-21 04:56:19 EST
Mine is Dell Dimension 450, desktop, video card is:
VGA compatible controller: nVidia Corporation NV18GL [Quadro4 NVS AGP
8x] (r
ev 162).
Comment 14 Jens Petersen 2004-02-25 07:29:19 EST
Nevermind, now it is crashing as soon as one selects
a ja install from boot.iso again.
Comment 15 Dave Jones 2004-02-25 09:51:17 EST
should be fixed in rawhide now (sys_shmat was broken briefly)
Comment 16 Jens Petersen 2004-02-26 21:25:58 EST
Still happening with kernel-2.6.3-1.109.
Comment 17 Jens Petersen 2004-03-01 01:40:18 EST
still segfaulting with kernel-2.6.3-1.116.
Comment 18 Nakai 2004-04-03 06:57:36 EST
Still happens with FC2 test2 .
Comment 19 Jens Petersen 2004-04-14 21:25:55 EDT
I just noticed that bterm segfaults too.  Is that the same issue?
Comment 20 Eido INOUE 2004-04-15 16:24:38 EDT
Comment 19: it sure looks like bterm and 2.6's way of doing the
framebuffer is the culprit.
Comment 21 Jeremy Katz 2004-04-15 17:23:26 EDT
Yes, definitely the same issue -- Adrian, debian has a newer bogl now.
 It might possibly work better (it's at least worth trying).
Comment 22 Jens Petersen 2004-04-16 00:04:06 EDT
Thanks, let me re-assign it to bogl, then. :)
Comment 23 Jeremy Katz 2004-04-16 13:54:33 EDT
And fyi, I've disabled the use of bterm in anaconda until this works
... having the installer segfault is less than useful and I'd rather
have it in English than just not work at all.
Comment 24 Nakai 2004-04-17 15:09:55 EDT
So, for nfs and other installation modes which start up with TUI,
could you let user to set favorite installation language once again
after anaconda GUI starts up?

Because
- Japanese users do mistakes with English message only
  and installation mistakes is sometimes critical
  (like partition blow away)
- Such failure voids translators works
- Bterm issue should not affect GUI installation language

We would meet again and again with this bterm fault with future
version of kernel, new cheap but popular video cards, or
unknown CPU architecture. And users want to use installer with
their favorite language at that time.
Comment 25 Nakai 2004-04-17 15:19:23 EDT
Umm, comment 24 is for comment 23.
This report is filed as bogl now...
Comment 26 Jeremy Katz 2004-04-17 23:15:00 EDT
Yes, this is how things currently work (we stay in English only until
we get to graphical mode where Japanese display is fine).  Basically,
you select Japanese in an NFS install and it tells you it's not
available until you get to the graphical portion of the install.
Comment 27 Leon Ho 2004-06-10 01:33:12 EDT
Debian had fixed it recently (0.1.18-1) for this problem. Can we have
a look and test it?
Comment 28 Akira TAGOH 2004-07-05 01:21:59 EDT
I've build bogl-0.1.18-1 on my test box, and it works fine on
2.6.7-1.457smp at least. Jeremy, could you update our bogl package to
0.1.18-1 ?
Comment 29 Akira TAGOH 2004-07-05 01:24:06 EDT
Created attachment 101630 [details]
modified spec file.diff
Comment 30 Akira TAGOH 2004-07-05 01:25:33 EDT
Created attachment 101631 [details]
a patch to replace bogl-0.1.9-rh.patch
Comment 32 Akira TAGOH 2004-07-07 21:32:02 EDT
this problem should be fixed in 0.1.18-1. please confirm it. thanks
Comment 33 Mike McLean 2004-07-13 18:18:20 EDT
Do we need to reenable bogl to test this fix?
Comment 34 Jeremy Katz 2004-07-13 18:54:56 EDT
A new bogl needs to make it into the build roots so that when I build
anaconda, the loader can link against it.  I've removed my "disable
bogl" patch for now.
Comment 35 Jens Petersen 2004-07-27 02:12:57 EDT
Kernel seems to oops now when doing a Japanese TUI nfs install.
Comment 36 Jeremy Katz 2004-07-27 13:36:03 EDT
Please file the oops as a (seperate preferably) kernel bug (and feel
free to cc me on it)
Comment 37 Akira TAGOH 2004-08-02 06:26:44 EDT
it works on rawhide-20040801. however when the vt is switched, the
rendering was screwed up, and it happens on anaconda only - switching
vt on bterm works fine.
Comment 38 Jeremy Katz 2004-08-02 11:47:38 EDT
What kernel are you not seeing rendering problems with?  I just tried
on my test box with 2.6.7-1.499 and see the rendering break running
just bterm when I switch vts (which makes me think it's not just anaconda)
Comment 39 Akira TAGOH 2004-08-05 08:27:53 EDT
I tried 2.6.7-1.499 too. but it works as I said. kernel was booted
with vga=0x31[12] and run bterm as root. was my test case different
with yours?
Comment 40 Jeremy Katz 2004-08-09 16:30:03 EDT
Yes, you want to be using vga16fb, not the vesafb stuff.

Boot and then modprobe vga16fb and then running bterm will initialize
the framebuffer, etc (exactly as anaconda does things).  
Comment 41 Akira TAGOH 2004-08-10 07:00:34 EDT
Thanks Jeremy. indeed, the rendering breaks when I switch vts and when
I exit from bterm - it works again when I'm back from the broken vts,
though. it looks like to me it's only difference between anaconda and
running bterm as usual.
Comment 42 Jeremy Katz 2004-08-10 11:15:55 EDT
The vga16fb and vesafb rendering are somewhat different drawing paths
form what I remember...
Comment 43 Lawrence Lim 2004-09-02 01:04:31 EDT
Problem still persist in rawhide-20040828.
Comment 44 Akira TAGOH 2004-10-07 03:25:26 EDT
just tried jfbterm with vga16fb. and I saw similar problem on that.
perhaps this bug should be reassigned to the kernel?
Comment 46 Akira TAGOH 2004-10-14 05:19:07 EDT
tried on 2.6.8-1.607. switching vt looks fine except exit bterm. when
I was back from bterm and vt scroll up, it's broken a bit. but it does
render correctly after switching back vt.
Jeremy, how can I do test if it works on anaconda? current kernel
looks much better than before. it's probably worth testing on anaconda
again.
Comment 47 Jeremy Katz 2004-10-14 09:38:41 EDT
I'll turn it on again for the next anaconda build.
Comment 48 Lawrence Lim 2004-10-18 01:38:33 EDT
Tested with anaconda-10.0.3.18-1.i386.rpm and
bogl-bterm-0.1.18-2.i386.rpm and the machine shut down automatically
after entering the NFS dir.

The text rendering in traditional chinese is good though.

Observation
- clicked ok, after entering the NFS installation path
- the screen background turn from blue to red
- output the graphical card
- crash

Comment 50 Jens Petersen 2004-10-18 11:21:41 EDT
*** Bug 131081 has been marked as a duplicate of this bug. ***
Comment 51 Jeremy Katz 2004-10-18 13:31:04 EDT
So we're defitely better off now, although still not completely good.

bterm linked against glibc seems fine, bterm linked against diet
doesn't.  Running bterm-diet and switching vts shows the same sig11 as
with it in anaconda (where we use diet to build the loader)

And I have a feeling that this is related to bug 134546...
Comment 52 Jeremy Katz 2004-10-18 17:23:24 EDT
With the frame buffer fixups plus the dietlibc fix for bug 134546, I
think we should be good once I build anaconda again (version will be
>= 10.0.3.20)
Comment 53 Akira TAGOH 2004-10-20 02:46:24 EDT
rawhide-20041019 should contains those fixes, right? signal 11 was
still occurred when I switched vt, though.
Comment 54 Lawrence Lim 2004-10-20 21:48:52 EDT
Tried with anaconda-10.0.3.21-1, signal 11 still occurred for me when
I switched vt.
Comment 55 Jeremy Katz 2004-10-20 22:56:04 EDT
You need a tree with anaconda >= 10.1.0 due to a series of silliness...
Comment 56 Akira TAGOH 2004-10-21 14:45:14 EDT
I've tested rawhide-20041021, and bogl works fine on both 1st stage of
TUI and GUI even if I switched vts. also, on 2nd stage, TUI installer
works on bogl, and GUI installer was realized properly.

Thanks Jeremy!

Note You need to log in before you can comment on or make changes to this bug.