Bug 1139166 - Limit number of notification retries
Summary: Limit number of notification retries
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: evolution
Version: 6.6
Hardware: All
OS: Linux
medium
high
Target Milestone: rc
: ---
Assignee: Matthew Barnes
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-08 09:22 UTC by Jiri Koten
Modified: 2014-10-14 04:41 UTC (History)
4 users (show)

Fixed In Version: evolution-2.32.3-34.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-14 04:41:25 UTC


Attachments (Terms of Use)
evolution backtrace (6.07 KB, text/plain)
2014-09-08 09:26 UTC, Jiri Koten
no flags Details
notification-daemon backtrace (5.38 KB, text/plain)
2014-09-08 09:28 UTC, Jiri Koten
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1416 normal SHIPPED_LIVE evolution bug fix update 2014-10-14 00:55:22 UTC

Description Jiri Koten 2014-09-08 09:22:59 UTC
Description of problem:
Currently when evolution don't receive reply on notification send, it tries to resend it indefinitely. This is causing a freeze of evolution and all gtk applications on my system. It lasts couple of minutes and even though I'm unable to reproduce on purpose, I experience it almost every day.   

Version-Release number of selected component (if applicable):
evolution-2.32.3-33.el6
evolution-data-server-2.32.3-21.el6
notification-daemon-0.5.0-1.el6
gtk2-2.24.23-6.el6
glib2-2.28.8-2.el6
at-spi-1.28.1-2.el6

Comment 1 Jiri Koten 2014-09-08 09:26:59 UTC
Created attachment 935281 [details]
evolution backtrace

Backtrace of evolution during freeze.

Comment 2 Jiri Koten 2014-09-08 09:28:51 UTC
Created attachment 935282 [details]
notification-daemon backtrace

Notification-daemon backtrace during freeze

Comment 3 Milan Crha 2014-09-08 12:34:31 UTC
Devel-acking, easy fix

Comment 6 errata-xmlrpc 2014-10-14 04:41:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1416.html


Note You need to log in before you can comment on or make changes to this bug.