Bug 1139267 - Undeploy Selected button on Storage Nodes page is disabled so it's not possible to remove second storage node
Summary: Undeploy Selected button on Storage Nodes page is disabled so it's not possib...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Storage Node, UI
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ER04
: JON 3.3.0
Assignee: Jirka Kremser
QA Contact: Filip Brychta
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-08 13:51 UTC by Filip Brychta
Modified: 2014-12-11 14:00 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-12-11 14:00:19 UTC


Attachments (Terms of Use)
screen shot (94.68 KB, application/octet-stream)
2014-09-08 13:51 UTC, Filip Brychta
no flags Details

Description Filip Brychta 2014-09-08 13:51:44 UTC
Created attachment 935359 [details]
screen shot

Description of problem:
$Summary

Version-Release number of selected component (if applicable):
Version :	
3.3.0.ER02
Build Number :	
4fbb183:7da54e2

How reproducible:
Always

Steps to Reproduce:
1. install and start JON3.3.0.ER02
2. deploy another storage node
3. navigate to Administration->Storage Nodes->Nodes
4. select newly deployed storage node

Actual results:
Undeploy Selected button is disabled

Expected results:
Undeploy Selected button is enabled and works

Additional info:
See attached screen shot

Comment 1 John Sanda 2014-09-09 03:13:24 UTC
I am reassigning to Jirka since he has handled pretty most of the storage node UI work.

Comment 3 Jirka Kremser 2014-09-17 15:14:21 UTC
branch:  master
link:    https://github.com/rhq-project/rhq/commit/cf1fca873
time:    2014-09-17 17:12:15 +0200
commit:  cf1fca873c0f8a59650b0c99fbc138e79626d719
author:  Jirka Kremser - jkremser@redhat.com
message: [BZ 1139267] - Undeploy Selected button on Storage Nodes page is
         disabled so it's not possible to remove second storage node -
         there was an error when checking if the storage node is
         available

Comment 4 Libor Zoubek 2014-09-18 08:54:48 UTC
branch:  release/jon3.3.x
link:    https://github.com/rhq-project/rhq/commit/2c59fdb32
time:    2014-09-18 10:42:06 +0200
commit:  2c59fdb3237c1f9b3521e7c99a32a4c515844fd1
author:  Jirka Kremser - jkremser@redhat.com
message: [BZ 1139267] - Undeploy Selected button on Storage Nodes page is
         disabled so it's not possible to remove second storage node -
         there was an error when checking if the storage node is
         available
         (cherry picked from commit
         cf1fca873c0f8a59650b0c99fbc138e79626d719) Signed-off-by: Libor
         Zoubek <lzoubek@redhat.com>

Comment 5 Simeon Pinder 2014-10-01 21:33:31 UTC
Moving to ON_QA as available for test with build:
https://brewweb.devel.redhat.com/buildinfo?buildID=388959

Comment 6 Filip Brychta 2014-10-07 07:10:23 UTC
Verified on
Version :	
3.3.0.ER04
Build Number :	
99d2107:d7c537e


Note You need to log in before you can comment on or make changes to this bug.